Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was attempting to upgrade SQL Server 2008 R2 Standard Edition to SQL Server 2008 R2 Enterprise Edition on a development VM. When I got to the "Select Instance" to upgrade page, the MSSQLSERVER instance (i.e., the standard instance I want to upgrade) was not available as an option; only SQLEXPRESS was an option (please see the attached screenshot).

A colleague who did the same process thought this was weird because he WAS able to see MSSQLSERVER as an instance; he chose that, and upgraded it successfully. I went ahead and chose SQLEXPRESS because I thought, well, if that's my only option, I guess I'll go ahead. But after the upgrade, which seemingly was successful, when I run management studio and check the version using T-SQL commands, it tells me it's still standard edition.

Now I'm sort of hosed, because I've got SharePoint running on the VM etc, and I'm afraid if I uninstall everything and start fresh to try and install Enterprise edition, I'll screw up my SharePoint installation etc. I'm backing up my VM as I type this just in case. But, any advice, kind people? Why couldn't the upgrade wizard see that instance? (I tried stopping the service for that instance but the wizard still didn't give that as an option, and now I can't upgrade anything). My next plan is to try and reinstall, but I fear I've may be stuck in "S-Q-L HELL". Thanks, -D

share|improve this question

migrated from stackoverflow.com Jun 9 '11 at 11:22

This question came from our site for professional and enthusiast programmers.

    
Oops, forgot to attach the screenshot, sorry. well, it's a picture of the upgrade wizard showing that only the SQLEXPRESS instance is available in the dropdown. –  David Barrows Jun 9 '11 at 10:38
    
What does SELECT @@VERSION, @@SERVERNAME give you for "both" instances? Are you mixing remote and local instances? AFAIK standard has some limitations on OS etc. And can you add some punctuation, paragrahs etc to make it readable... –  gbn Jun 9 '11 at 10:42

1 Answer 1

It turns out I was selecting "Installation... Upgrade" instead of "Maintenance... Upgrade Edition", which did allow me to specify the desired instance.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.