Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've installed Strawberry Perl (v5.12.3) on Windows Server 2008 32 bit and I was hoping to run simpledb CLI tools.

I had a small issue with HOME environment variable, I renamed it to HOMEPATH to solve the problem, but when I tried to run I got:

This application has failed to start because libeay32_.dll was not
found. Re-installing the application may fix this problem.

Anyone knows how to solve the problem? Is it an issue of Strawberry Perl?

share|improve this question
    
I've run a search in my disk and found that libeay32_.dll is located in d:\perl\c -- so I think to solve the problem I've to find a way to let perl look in that directory for DLLs –  stivlo Jun 9 '11 at 17:44
    
It's actually located in d:\perl\c\bin and that directory is listed in my PATH variable. –  stivlo Jun 9 '11 at 17:51
    
As a temporary hack until someone suggest me a better solution, I've copied libeay32_.dll in the same directory of perl.exe - It is found only if I first cd to perl bin directory and run perl from there. Now it complains that it can't find libssl32_.dll, so I think I've to repeat this workaround for a few libraries. –  stivlo Jun 9 '11 at 17:55
    
Next in line I found errors for libxml2-2_.dll, libiconv-2_.dll, and libz_.dll -- after copying them, it works. However I hope that someone suggests a better solution. –  stivlo Jun 9 '11 at 18:05

2 Answers 2

I've corrected the problem by removing perl path statements in the windows environment variables. They were at the beginning of the string from an old install. The strawberry install added it's own path statements at the end. This allowed the new strawberry intall to search the paths in the correct order.

share|improve this answer

I had the same problem with Windows Server 2003, strawberry, and Bugzilla. My "solution" was to copy the missing .dll files to c:\windows\system32, whenever the system told me that it couldn't find a dll. The missing .dll files were all in the path. Previously I tried copying them to the directory where perl.exe is, and other places, but nothing worked. The only exception was the libmysql_.dll file, which worked when copied to the /strawberry/perl/vendor/lib/auto/DBD/mysql directory.

Hopefully someone will find the real problem and/or fix for this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.