Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm installing gentoo Linux and I just installed my kernel, but has to configure.

When I compile my kernel with make && make modules_install, it gives me an error in the end saying:

arch/x86/boot/boot.h: Assembler messages:
arch/x86/boot/boot.h:122: Error: bad register name '%dill'
make[1]: *** [arch/x86/boot/video.o] Error 1
make: *** [bzImag] Error 2

I have tried genkernel and manually configuring my kernel, by both gives me the same error; I used make menuconfig and not emerge genkernel.

Can anyone please help me?

share|improve this question

migrated from Jun 9 '11 at 19:50

This question came from our site for professional and enthusiast programmers.

how about some hardware specifications of the machine you're compiling on? – lkraav Jun 9 '11 at 22:49

One way or another, your compiler isn't correctly configured. Without more hardware specs, this is, I think, the best a person can do:

The Gentoo guide to optimizing (aka for a first time gentoo install: configuring,) your compiler is at

If you need further help, post your cat /etc/make.conf, cat /proc/cpuinfo, and for good measure, then env output from your bash session, although your bash session's env will probably reveal nothing of value unless make.conf is fine.

PS: Be sure to run make clean after changing anything compiler related in make.conf, in case it finished anything and left it laying around.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.