Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Looks like Xen 4.1 went through some major changes as far as networking goes. With that said, I have two NICs on the host. eth0 and eth1. I want dom0 to be accessible via eth0 and only eth0. I want eth1 for ALL virtual machine traffic.

I went through the configuration and setup the bridge via /etc/sysconfig/network-scripts/ifcfg- per the wiki.

I have it working where I'm able to log into the dom0 and created a VM. However, my VM doesn't go over eth1. Looks like it attached itself to the default bridge that was automatically created during initial setup (virbr0).

share|improve this question
    
nope, not Citrix just the original Xen. –  luckytaxi Aug 31 '11 at 12:51
    
ok - I deleted my comment. It's alway helpful to know which linux distro is in use (CentOS in your case - BTW which version?). –  Nils Sep 12 '11 at 20:07
add comment

1 Answer

What distribution is this?

In your Xen domu configuration files, you can define the bridge they should attach to in the vif setting:

vif=[ 'mac=00:16:3e:11:11:26,bridge=br0,model=rtl8139', ]

Change br0 to which ever bridge you want to connect them to.

share|improve this answer
    
Running Centos, i finally got it working, I had to delete the default bridge. I dont think there's a domu config file in 4.1. –  luckytaxi Jul 14 '11 at 12:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.