Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My Windows 7 Ultimate N SP1 64bit workstation is configured to synchronize with a local Debian squeeze NTPd. After triggering synchronization manually from the configuration dialog, Windows claims to have successfully synchronized its clock, but is still tens of seconds off.

What can be done to improve Windows' behaviour here?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

The clock will be adjusted by not resetting the value but by speeding up or slowing down the clock until it reaches the reference value. This is done to prevent "time jumps" in things like application or system logs and will only happen as long as the deviation does not exceed a certain value (300 seconds as the default for domain members, explicit value can be specified as MaxAllowedPhaseOffset in the registry). Technet has the details about the Windows Time Service.

share|improve this answer
    
Indeed! Meanwhile the workstation has synchronized to a manually verified accuracy in the 1-second range. –  David Schmitt Jun 10 '11 at 11:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.