Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm currently already running php 5.2.14, so I'm hoping this means I should be able to find a package or method to install php-mbstring 5.2.14 without having to go through any uninstalling or downgrading routine.

Yum is only reporting the following packages as available:

$ yum list available|grep mbstring
php-mbstring.i386                          5.3.6-3.el5.art               atomic 
php-mbstring.x86_64                        5.3.6-3.el5.art               atomic 
php53-mbstring.x86_64                      5.3.3-1.el5_6.1               updates

Which all obviously come with php 5.3 dependencies across the board.

The server is in use by a number of people, although not publicly so it would be a few bored developers rather than angry clients if the server had to be done due to lengthy install or compiling, but the less disruption the better.

Does anybody know of the least disruptive way to achieve what I'm trying to do? Thanks!

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted
  1. Look for the package in somebodies old mirror.
  2. Compile the package yourself using the distro spec file at the version you want. (You will likely run into trouble installing -devel packages because those are going to be missing from current repositories too.)
  3. Bite the bullet and upgrade! If it was a production box you should have some kind of stand-in machine or system to ugprade anyway, and if it's just a devel box send out an announcement and just do it. If upgrading goes agaist your religion or breaks your developers code, you shouldn't be using a distro that keeps their repositories up to date with current versions!
share|improve this answer
add comment

Try one of the 3rd party repos like EPEL, RPMForge or Remi.

I know remi does some good work on PHP so check it out @ http://rpms.famillecollet.com/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.