Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Using my administrator account, I FTP connected to my IIS 7.5 FTP Site with FileZilla. I was able to successfully upload a file, but I keep getting a "Failed to retrieve directory listing" in response.

In passive mode, the command, response and error are:

Command:    LIST
Response:   150 Opening BINARY mode data connection.
Response:   550 The network connection was aborted by the local system. 
Error:  Failed to retrieve directory listing

In active mode, the command, response and error are:

Command:    PORT 192,168,1,129,102,151
Response:   501 Server cannot accept argument.
Error:  Failed to retrieve directory listing

What have I done wrong?

share|improve this question

5 Answers 5

Sounds like Firewall configuration issue. Please have a look at this article (if you have not done it already): http://learn.iis.net/page.aspx/309/configuring-ftp-firewall-settings/

share|improve this answer

I was having this issue as well and it was related to the data ports being selected by IIS. I set it up to use a specific port range but when my client tried to use passive mode it showed that it was using the wrong port.

This article describes the method for calculating which port it is using. e.g.

227 Entering Passive Mode (x1,x2,x3,x4,y1,y2)

The IP it would be using is x1.x2.x3.x4 and port (y1*256) + y2. I was seeing the wrong values for y1 and y2 so I had to restart "Microsoft FTP Service" to actually get it to recognize the values I had set in the FTP Firewall Settings in IIS.

share|improve this answer

I had same problem, but I've got a solution.

Check your location path ftp directory and add user everyone with full access for this folder.

share|improve this answer

I had the same error on Windows 2008 Server and had to allow everything (Passive ports) on both my firewall and on Windows Firewall (Public Profile) and had to upgrade from IIS 6.0 FTP to IIS 7.5 FTP.

share|improve this answer
    
That's a very drastic firewall solution to a specific problem. –  itsbruce Oct 18 '12 at 7:54
    
I do not mean all ports, but all FTP passive ports –  Alexandre Marcondes Oct 18 '12 at 14:35

Here is a solution from Microsoft.

http://www.iis.net/configreference/system.applicationhost/sites/sitedefaults/ftpserver/directorybrowse

Installing the FTP Extensibility feature and enabling listing under Directory browsing, solved my issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.