Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have an old C program which has traditionally been run from SCO boxes. We have a customer that went with RackSpace running RHEL and we got the app recompiled. We have a problem with terminal emulation though. We've been trying PuTTY over SSH, but we can't seem to get the emulation settings right so that we can use the keyboard, arrow keys, and numeric keypad. We've tried SCO, linux, Xterm, VT100+. If we use ansi_sysk, the number pad works, but arrow keys don't. If we use xterm, the arrow keys work, but number pad doesn't.

Anyone have suggestions?

share|improve this question

migrated from stackoverflow.com Jun 10 '11 at 19:18

This question came from our site for professional and enthusiast programmers.

2 Answers 2

I would try Ericom Powerterm, specifically with the SCO-ANSI emulation mode. I've worked with a legacy application for years where PuTTY required heavy modification to get the font, display and keybindings to work properly. Powerterm always worked out of the box, but is a commercial application, so cost became an issue.

share|improve this answer
    
Thanks. Looks like the client has telnet closed, so I'm working to get them to open it up. We are going to give this a shot. –  Mark Freeman Jun 10 '11 at 20:06
    
Telnet is probably a bad idea, as it sends authentication data in the clear –  Ed L Jun 10 '11 at 21:15
    
It's a legacy app. Sometimes SSH is not available. –  ewwhite Jun 10 '11 at 22:20

SecureCRT has to be the benchmark for native Windows ssh clients. Highly configurable with a design that fits well in to a Windows workflow. It's a paid application so, as with most paid apps, means you can email their support for issues.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.