Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got my regular wamp installation, and everything has been working fine with other vhosts, until I tried to make a vhost for DooPHP framework and I got an ssl_error_rx_record_too_long error on Firefox. It loads up fine in Chrome. I'm not using any SSL certs. My vhost configuration is just like all the rest of them:

<VirtualHost *:80>
   ServerAdmin arturas@duomenucentras.lt
   DocumentRoot "C:/wamp/www/doophp/"
   ServerName doophp
   ServerAlias doo
   ErrorLog "logs/doo-error.log"
   CustomLog "logs/doo-access.log" combined
   <Directory "C:/wamp/www/doophp/">
       Options Indexes FollowSymLinks Includes
       AllowOverride All
       Order allow,deny
       Allow from all
   </Directory>
</VirtualHost>

Any ideas?

Edit:

Ok, now it stopped saying ssl_error_rx_record_too_long and just says "Firefox can't establish a connection to the server at doo.". It loads up and works in Chrome, IE, Safari, Opera. Just not Firefox. What is up with that?

share|improve this question

closed as off-topic by Tom O'Connor Aug 14 '13 at 20:51

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is a site dedicated to professionals; novice questions are off-topic. Please see the Help Center for more information on topicality. The best advice we can give you is to hire a professional to help you out." – Tom O'Connor
If this question can be reworded to fit the rules in the help center, please edit the question.

You forgot to enable SSL. You need this in your virtualhost entry

    SSLEngine on
    SSLCertificateFile /etc/apache2/yourhost.pem

If you have bought a cert you can use that or

    openssl req -new -newkey rsa:2048 -days 365 -nodes -x509 -keyout yourhost.pem -out yourhost.pem

Edit: are you sure your app does not redirect to ssl?

The message you got is the one you got when you speak https with a http server.

share|improve this answer
    
the thing is, i'm not using any certificate (it's just test of DooPHP framework) - and other virtual hosts work fine. – donkapone Jun 11 '11 at 19:19
    
I re-read your question and made some updates – cstamas Jun 11 '11 at 19:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.