Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an Apache http server running on my computer, listening to port 80. I can access my "hello world" page by visiting http://localhost/ in my browser. I've also set up a static IP address, so that I can access the same page by visiting http://192.168.0.35/

I recently changed apartments/roommates, so I've also switched routers. Before I moved, I was using a Netgear router (I can't remember the exact model), but I was able to access my page via the external IP address, just by forwarding port 80 to my computer. Now I'm on a SMC8014W-G, so I followed this guide to set up the forwarding. I also used their port checker program to verify whether the ports (80, 443-just-in-case) were being forwarded. According to that program, they are being properly forwarded (and I checked a few random other ports, to make sure it wasn't giving me false positives).

As far as I can tell, I've done everything I need to do to make it so I can access my site from my external IP address, but it's just not working! Have I missed some crucial step? What could be wrong?

share|improve this question

migrated from stackoverflow.com Jun 11 '11 at 20:27

This question came from our site for professional and enthusiast programmers.

    
192.168.0.35 is a private address that will not be routed outside your private network. it used to point to your localhost before you moved, right? Do i understand that correctly? –  mkro Jun 11 '11 at 2:09
    
To be clear, I still have access to the old router (which will be gone soon), but I no longer have a static IP set up. Within that local network, I find my port number via ipconfig, then just tell the router to forward to that one. It works from there. –  Dylan Halperin Jun 11 '11 at 8:29

3 Answers 3

Do you still have the same static IP of 192.168.0.35? It's possible you have a different IP and could be on a different subnet with the new router.

Possibly not a stackoverflow question as well.

share|improve this answer
    
I re-ran ipconfig just to be sure: In the results I have IPv4 Address. : 192.168.0.35 Subnet Mask . : 255.255.255.0 Default Gateway . : 192.168.0.1 (sorry, I can't seem to make that format the way I want) –  Dylan Halperin Jun 11 '11 at 8:25

I would suggest checking to see if your provider may be blocking the access. If you go to GRC and select shields up you can run a portscan of your device remotely. If the port doesn't show as open, you might try forwarding your server to something like 8080 or 8001 to see if your provider allows that access.

share|improve this answer
    
I followed your advice and ran the portscan, picking the "common ports" option. Out of the results, only port 80 was open. All others were "Stealth." –  Dylan Halperin Jun 13 '11 at 5:27
up vote 0 down vote accepted

I had not realized this, but apparently some routers (e.g. mine) don't let you use your external IP address to access your own network. I visited my external address from a different network and was able to see the home page being served by my own server.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.