Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've noticed that powertop utility reports "Bad" "Runtime PM for PCI Device" for several devices. Seems that powertop can fix the issue but it won't tell what exactly it does to fix it. What should I do to fix that "Runtime PM..." issue?

share|improve this question

3 Answers 3

Since the bios 2.11 update on the UX32VD this rule breaks usb device auto detection. I don't really know how, but since then to detect usb devices, the xhci_hcd module must be reloaded after a usb devce is connected to detect it.

share|improve this answer
    
Is there any fix known? –  Andreas Mueller Dec 9 '12 at 11:15
    
How to reload the xhci_hcd module? –  akaihola Mar 31 '13 at 6:32
    
@AndreasMueller check help.ubuntu.com/community/… for a possible work-around – disabling power management for the xHCI chip only. –  akaihola Mar 31 '13 at 6:37

This CrunchBang Linux forum thread helped me to solve this.

You enable PM for each of your PCI devices this way :

echo auto > /sys/bus/pci/devices/*/power/control 

The forum thread shows a nice powersaving script btw.

UPDATE: was cat, but echo is correct

share|improve this answer

Create a file called /etc/udev/rules.d/10-runtime-pm.rules with the following content:

SUBSYSTEM!="pci", GOTO="power_runtime_rules_end"
ACTION!="add", GOTO="power_runtime_rules_end"

KERNEL=="????:??:??.?"
PROGRAM="/bin/sleep 0.1"

ATTR{power/control}=="*", ATTR{power/control}="auto"

LABEL="power_runtime_rules_end"

After a reboot runtime PM should be enabled for all devices that support it. It is also enables it for all hotplugged devices.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.