Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I connect to a production machine (Windows Server 2008) using Remote Desktop Connection (via mRemoteNG client) directly from my home computer. I would like my to save password, so that I don't have to type it each time.

Unfortunately, there are some policy restrictions, because when I connect with saved password I'm getting the following message:

"Your credentials did not work The server's authentication policy does not allow connection requests using saved credentials. Please enter new credentials."

What exactly has to be configured on the server to allow me to keep the password saved on my machine?

share|improve this question

migrated from stackoverflow.com Jun 12 '11 at 17:31

This question came from our site for professional and enthusiast programmers.

    
Are you the user or admin? Also are you using domain\user or user@domain.local in the onnection also how do you connect to the server, vpn or....... – t1nt1n Apr 22 '12 at 6:41

Go to "Remote Desktop Session Host Configuration" --> Right click on "RDP-Tcp" Under "Connections" and go to Properties --> Go to the "Log on Settings" tab and uncheck "Always prompt for password"

share|improve this answer

To be able to use saved credentials in this situation you need to do the following in your Windows 7 machine:

  1. Open Group Policy Editor via cmd -> gpedit.msc
  2. Navigate to Local Computer Policy > Computer Configuration > Administrative Templates > System > Credentials Delegation
  3. Open Setting Allow Delegating Saved Credentials with NTLM-only Server Authentication, set it to Enabled click on button Show... and in Show Contents window add Value TERMSRV/*.
  4. Close all windows by pressing OK.
  5. Run cmd and enter gpupdate /force command to update your policy.

Now you should be able to use your saved credentials.

Note: Credentials are ONLY saved when a host or DNS name is supplied. When it's an IP address it will never save the credentials.

References: here

If you don't want to change anything on local or server side, Do this:

  1. Go to Control Panel -> Credential Manager. You will see three sections:
  2. Add your credentials under Generic Credentials.

    Now you can RDP without entering password.

Answer can also be found here in the similar question.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.