Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My service for World Wide Web Publishing Service started successfully but whenever I browse to http://localhost/ I always get 502 Unknown host. Also, wampapache is installed side by side but when I stop IIS service and start wampapache from services.msc I get error and when I view it in System event log I get this error:

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" /> 
  <EventID Qualifiers="49152">7024</EventID> 
  <Version>0</Version> 
  <Level>2</Level> 
  <Task>0</Task> 
  <Opcode>0</Opcode> 
  <Keywords>0x8080000000000000</Keywords> 
  <TimeCreated SystemTime="2011-06-12T17:43:28.223498400Z" /> 
  <EventRecordID>346799</EventRecordID> 
  <Correlation /> 
  <Execution ProcessID="456" ThreadID="3936" /> 
  <Channel>System</Channel> 
  <Computer>MACHINENAME</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data Name="param1">wampapache</Data> 
  <Data Name="param2">%%1</Data> 
  </EventData>
  </Event>

I am fed up of this error and it is driving me nuts. I feel like banging my head against the laptop. I am really serious. Without concentrating on my real application I am trying to solve this issue since 3 hours.

I google various threads and few of them said that there could be issue of Reporting Services or Skype. But I have uninstalled Skype and Reporting Services are disabled. What more should I do?

I have hosts file present in etc directory and it does have mapping for localhost to 127.0.0.1. What more could I do?

share
    
navigating to 127.0.0.1 works? –  DarkCthulhu Jun 12 '11 at 17:52
    
Navigating to 127.0.0.1 doesn't work either. –  TCM Jun 13 '11 at 2:18
    
Any other loopback address? 127.1.1.0... etc? –  DarkCthulhu Jun 13 '11 at 5:05
comments disabled on deleted / locked posts

migration rejected from stackoverflow.com Aug 14 '13 at 20:56

This question came from our site for professional and enthusiast programmers. Votes, comments, and answers are locked due to the question being closed here, but it may be eligible for editing and reopening on the site where it originated.

closed as off-topic by Tom O'Connor Aug 14 '13 at 20:56

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is a site dedicated to professionals; novice questions are off-topic. Please see the Help Center for more information on topicality. The best advice we can give you is to hire a professional to help you out." – Tom O'Connor
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

Have you configured the binding in IIS manager?

Right click on your site, select 'Edit Binding', ensure as a minimal port 80 is added, host name and IP address (leave as default - All Unassigned) does not need to explicitly be defined if you are typing in localhost.

If you want to run side by side, change the port number or hostname.

share
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.