Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a haproxy / stunnel server that handles SSL for our sites on AWS. During testing I created a self signed cert on this server and hit it from my desktop using Chrome to test that stunnel was working correctly.

Now I have installed the legitimate cert on that server. When I hit the site from my machine in Chrome it throws the following error:

Error 113 (net::ERR_SSL_VERSION_OR_CIPHER_MISMATCH): Unknown error.

My guess is that Chrome cached the key for the self signed cert and it doesn't match that of the legitimate cert? This site works in all other browsers on my machine so it is just a Chrome problem.

One interesting note: When hitting the page from a incognito session (ctrl-shift-n) it works correctly. So it is clearly some sort of cache thing.

I did all the things I could think of (dumped my cache, deleted certs from the Personal and Other People page in the Manage Certificates dialog, ctrl-F5 etc...)

My machine is Windows 7 x64 Chrome version : 12.0.742.91

Any ideas?

EDIT: I found this link, it sounds like my issue but no resolution http://www.google.com/support/forum/p/Chrome/thread?tid=685998387b6d8d86&hl=en

UPDATE So it seems to have "fixed itself" today. I hate problems like this. I still don't know what caused it or how it resolved itself, presumably the cached cert expired or something but I am still interested to know where this information is stored and how to verify it.

share|improve this question

2 Answers 2

AFAIK certificates are not specific for Google Chrome (at least on Windows) but to the whole system. You've already deleted that cert through Chrome interface so it should gone. But try Start -> Run -> certmgr.msc anyway.

Another tool to try CCleaner -- it should help with better cleaning of the Chrome caches.

share|improve this answer
    
Tried certmgr.msc and I don't see the cert in there. Like you said it is clearly gone since the other browsers do the right thing, maybe this is just a chrome bug of some sort –  Foovanadil Jun 13 '11 at 18:36
    
So ... did you had any luck so far? Have you tried CCleaner as suggested? .. or any other tool? –  LazyOne Jun 14 '11 at 9:00
    
I ran CCCleaner and looked at what it wanted to delete and it was nothing more than what Chrome will delete (Just cookies and session info). –  Foovanadil Jun 14 '11 at 16:38

Many problems with SSL certificates can be solved by simply removing the file from the cache folder cert8.db in firefox. The same happens in chrome/chromium, but the file to be removed is the cert9.db folder ~/.pki/nssdb.

Attention! Removing these files will need to re-register CAs in your browser.

Hope that helps, although the tip is not for windows users. Sorry for my English. Google translator portugues (Brazil).

share|improve this answer

protected by Michael Hampton Oct 21 at 13:23

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.