Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was changing some settings on my dedi box to do with adding more descriptors and then rebooted. Since then I cannot log into SSH with root details (or anyone else). As soon as I log in, the putty screen just closes. When I ssh user@domain.com from my other VPS, it logs in then says Connection Closed.

I am really stuck now as I have lost shell access to my server and only have plesk ..

EDIT: Verbose output from ssh -v

debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to domain [IP] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: identity file /root/.ssh/identity type -1
debug1: identity file /root/.ssh/id_rsa type -1
debug1: identity file /root/.ssh/id_dsa type 2
debug1: loaded 3 keys
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3
debug1: match: OpenSSH_4.3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.3
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'domain' is known and matches the RSA host key.
debug1: Found key in /root/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Next authentication method: gssapi-with-mic
debug1: Unspecified GSS failure.  Minor code may provide more information
Unknown code krb5 195

debug1: Unspecified GSS failure.  Minor code may provide more information
Unknown code krb5 195

debug1: Unspecified GSS failure.  Minor code may provide more information
Unknown code krb5 195

debug1: Next authentication method: publickey
debug1: Trying private key: /root/.ssh/identity
debug1: Trying private key: /root/.ssh/id_rsa
debug1: Offering public key: /root/.ssh/id_dsa
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Next authentication method: password
root@domain's password:
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Sending environment.
Last login: Tue Jun 14 00:05:36 2011 from 02dc9b0a.bb.sky.com
debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: channel 0: free: client-session, nchannels 1
Connection to domain closed.
debug1: Transferred: stdin 0, stdout 0, stderr 35 bytes in 0.3 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 106.5
debug1: Exit status 254

Any ideas?

share|improve this question
1  
Please add '-v' to your ssh command, or perhaps even '-vv' - this will enable verbosity and you might get a clue as to why your connection is being closed. –  draeath Jun 13 '11 at 21:00
    
I have added the verbose output into my original post. –  webnoob Jun 13 '11 at 21:08

2 Answers 2

up vote 3 down vote accepted

Kyle is definitely right about one thing - your shell is not being spawned properly. But that exit status makes me think that it's a problem with the shell itself, not the machine being unable to fork a process.

If I had to guess, I'd say your shell has been disabled - possibly by setting it to /bin/false or similar.

share|improve this answer
    
Is it something I can fix? Hosts are planning on charging me £60 + VAT per 30 mins and they want to do a full re-install ... I simply can't allow that :( –  webnoob Jun 13 '11 at 21:25
    
Well, it depends on what is causing it. You can try using Plesk to reset your shell to /bin/bash, or using it to create another user and attempting to login as that. You could also try running a command directly on the ssh line, which would spawn a different type of shell which might work. But either way, it is concerning that your shell changed (if that, indeed, is what happened), and your machine may have been compromised. –  Scrivener Jun 13 '11 at 21:29
    
Ok, via FTP I have a passwd file in the etc folder that contains: root:*:0:0:Root:/:/bin/false otheruser:x:10002:2522::/:/bin/bash I cannot edit this though. Would this cause the issue? –  webnoob Jun 13 '11 at 22:37
    
If you were trying to login as root, then yes, that would cause it. –  Scrivener Jun 14 '11 at 12:42

Your system may actually have exceeded the number of allowed processes, which would result in sshd being unable to spawn your shell. I'm not familiar with Plesk, are you able to use it to stop troublemaker services?

share|improve this answer
    
I don't think so ... I wouldn't know where to look. Only been using Plesk for a week :/ –  webnoob Jun 13 '11 at 21:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.