Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install the perl module Statistics::Basic::Mode on a RHEL 5 system and am having issues.

I have tried MCPAN and RPM. Here is the result of running

sudo perl -MCPAN -e shell > output2.txt

install Statistics::Basic::Mode

Link to CPAN results

When I tried to install it using rpm I used the following:

Link to site where I got the rpm

I ran the following: sudo rpm -i perl-Statistics-Basic-1.6601-2.el5.rf.noarch.rpm

I get the following: error: Failed dependencies: perl(Number::Format) >= 1.61 is needed by perl-Statistics-Basic-1.6601-2.el5.rf.noarch

so I tried to install Number::Format, but the response I get is that it is up to date. I am not sure where to go from here. Any advice would be great. Thank you

share|improve this question

1 Answer 1

Is Number::Format at the correct version? It's possible that the version in your repos is too low. It's also worth making sure that Number::Format is in your @INC. If it's not, you could add the path to it into $PERL5LIB, and try installing again?

share|improve this answer
    
I will give that a shot, thank you –  Alos Diallo Jun 17 '11 at 12:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.