Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There is a mail server that I'm trying to test using telnet. I telnet to the server on the port and it responses with "220 ******************************************" The server is exchange and sending of mail requires authentication.

When I enter the command "helo" I get "500 5.3.3 Unrecognized command" no matter what I enter, even "quit" I get the same response. The website MXToolbox ( says that the mail server is responding properly.

What could be wrong?

share|improve this question
up vote 3 down vote accepted

If the response truly is

220 **********************
then the answer is that, contrary to what you might think, you are not talking to a Microsoft Exchange SMTP server.

Rather, you're talking to a Cisco router with the "mailguard" mechanism enabled, as Microsoft explains to those who think that they have Exchange problems. As Cisco says, if you want to talk to a Microsoft Exchange server — or to any other server that requires SMTP extensions such as SMTP AUTH, for that matter — you must disable the "mailguard" mechanism and let the world talk to your actual server.

share|improve this answer
So then, how is able to communicate with it properly? – user61925 Jun 14 '11 at 16:53
It's not exclusive to Cisco, although Cisco does respond with that. I think WatchGuard and/or SonicWall also utilize similar responses along with other SMTP proxies. – user48838 Jun 14 '11 at 18:01
Untrue. WatchGuard responds 220 SMTP service ready and SonicWall responds 220 SMTP SonicWALL (w.x.y.z). Of the three, it is only Cisco routers that respond with the asterisks. – JdeBP Jun 15 '11 at 15:23
mxtoolbox doesn't perform a full SMTP transaction, and isn't the acid test that you think it to be. – JdeBP Jun 15 '11 at 15:26

You are more than likely running into a SMTP proxy, either on the router or firewall.

share|improve this answer
"So then, how is able to communicate with it properly?" It may be set to ESMTP-only in which case it would be "ehlo" instead of the "helo" command string. – user48838 Jun 14 '11 at 18:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.