Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm getting that error when trying to execute trac-admin /path/to/trac repository resync /path/to/svnroot/repo1

Both paths exist. I'm trying to use Trac 0.12 with several svn repositories. I could resync the first one without problems, but the second one causes that error. Now, I can't resync any of them. I always get a error like this:

$ trac-admin /path/to/trac repository resync /path/to/svnroot/repoN

TracError: Repository '/path/to/svnroot/repoN' not found.

And the repository does exist. Tested.

Software used: Ubuntu 10.04, Trac 0.12, Subversion 1.6.12, Python 2.6, Apache2 + mod_wsgi.

Things done:

  • Svn repositories created and tested, working well.

  • Trac initenv and deploy admin operations executed in trac directory.

  • Apache configured adding these lines to /etc/apache2/mods-enabled/ dav_svn.conf:

My repos are /path/to/svnroot/repo1 and /path/to/svnroot/repo2.

And these lines were added to /etc/apache2/conf.d/trac.project.conf

Same passwords are used for svn and trac: /etc/apache2/dav_svn.passwd, created with htpasswd.

Any clues about the TracError problem? Thanks in advance,

Best regards, Jorge

share|improve this question
up vote 3 down vote accepted

In fact, when you use trac-admin /path/to/trac repository resync myrepository you have to specify myrepository by it's name and not by it's path (repoN in your case).

share|improve this answer

I think I solved my problem. The trick was to execute:

trac-admin /path/to/projenv repository resync '*'

With that instruction, I could resync all my repos :-).

Thanks for your help!

share|improve this answer
it also list repos, which helped me since my repos had trailing '?' not seen in trac – fantastory Sep 11 '14 at 8:31

Based on the documentation, I'm guessing that at some point you were supposed to assign the repository some kind of name for that path with the

repository add <repos> <path>

command, then all of the other commands refer to that <repos> name instead of the <path>.

share|improve this answer
I added the repository from trac admin the first time, and it worked. But when I tried with the second repository (add from admin page and the resync from console) I get that error. And I'm a bit confused about the add command syntax <repos> = path to my repository?, what is <path>? – jorgeas80 Jun 15 '11 at 22:28
I think it's supposed to be a name (I use trac without svn so I'm not sure). Like repository add MyProject /some/directory/somewhere then you have a repository that trac calls "MyProject" and every other trac command uses "MyProject" rather than "/some/directory/somewhere". – DerfK Jun 15 '11 at 22:54
I can add the repo with this instruction, and it appears in the trac "Browse Source" section, but without code. If I try to execute trac-admin resync (I had to do it with the first repo) I get a "Error: repository not found" message. And it exists :-( – jorgeas80 Jun 17 '11 at 9:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.