Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm working with Exchange 2010 and Blackberry Enterprise Server Express v5.0 SP1. Both are installed on 64bit Windows 2008 Standard servers. Our present mail server say MX1, has all the mailboxes. We're introducing a new Exchange 2010 (call it MX2) to load balance the messaging stores. I'm trying to move mailboxes from MX1 to MX2. However when I move a mailbox for a user who has a Blackberry, his blackberry stops working. I look around on the web and blackberry support forums and everyone mentions using the handheldcleanup.exe utility for the mailbox I moved.

When I run that utility like so

handheldcleanup -u -p "Profile Name"

I get the error

BlackBerry Enterprise Server Utility - HandheldCleanup.exe, Version 2.0
Copyright (c) Research In Motion, Ltd. 2000-2001. All rights reserved.
Attempting MAPILogon....
MAPILogonEx() failed (80040111)

I get the same error no matter what I do with the handheldcleanup utility (there are options to dump settings to file etc)

Note I have installed the MapiCdo v1.2.1 package. Also I'm running this logged into the blackberry windows server as BESAdmin user.

Anyone have any ideas?

share|improve this question
add comment

1 Answer

There are two answers in the literature. The issue is that BES does not know the new database is there. You can re-run the BES install, and add the additional Exchange databases during the installs, or I suspect you can simply add the database permissions for the new exchange server into the mix.

  1. On a computer that hosts the Microsoft® Exchange Management Shell, open the Microsoft Exchange Management Shell.

  2. Type Get-MailboxDatabase | Add-ADPermission -User "BES service account name" -AccessRights ExtendedRight -ExtendedRights Receive-As, ms-Exch-Store-Admin

Or apply permissions specifically to the newly created database:

Get-MailboxDatabase "new database name" | Add-ADPermission -User "BES service account name" -AccessRights ExtendedRight -ExtendedRights Receive-As, ms-Exch-Store-Admin

This is a real problem with BES, and 2010 DAG groups, as well. Sunny Lowe

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.