Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I changed MailFrom="" in /usr/share/logwatch/default.conf/logwatch.conf

That altered "From:" in the headers, but "Sender:" is still "root@ip-xx-xx-xx-xx.domain"


EC2 Linux AMI beta, Postfix is the mailer

share|improve this question
    
Changing default mailer to use -> mailer= "sendmail -t -f user@your.domain" helped. –  Offspring2099 Jun 14 '11 at 18:22
add comment

1 Answer

Arrived here via google with the same problem.

Adding the "-f user" option to sendmail in /usr/share/logwatch/default.conf/logwatch.conf had no effect.

Turns out logwatch.pl processes /usr/share/logwatch/dist.conf/logwatch.conf after /usr/share/logwatch/default.conf/logwatch.conf.

Edit or remove the MailFrom = root override in /usr/share/logwatch/dist.conf/logwatch.conf for it to work.

share|improve this answer
    
Agree with editing /usr/share/logwatch/dist.conf/logwatch.conf. But also check the script (if any) executed by cron for more overrides. For Ubuntu (Precise) this is in /etc/cron.daily/00logwatch. If the package maintainer overwrites these you will need to revisit them. –  user139734 Nov 17 '12 at 20:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.