Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a local server running Redis, Mongo, and MySQL servers. I can access it with its LAN IP address (192.168.*. *), but I can't access it by its CNAME. I have the server set up in the DMZ of our local router. If I run a Rails server at port 3000 I am able to see it at the CNAME ( For the mysql server when I try to login using the CNAME I get an error:

ERROR 1130 (HY000): Host '**************' is not allowed to connect to this MySQL server

I am running Ubuntu and have configured ufw (front end for IP tables) to allow all on

Do I need to make sure each of the ports are port forwarded on the router?

share|improve this question
up vote 1 down vote accepted

This does not sound like a firewall issue, since you get the error from MySQL already.
More likely, since you are accessing the MySQL server now via the CNAME you are not coming from a allowed IP anymore but from your gateway IP (or similar, hard to say without knowing your network layout).
Check MySQL privileges.

share|improve this answer
Thanks, but I can fix the MySQL problem. Redis and Mongo were the main concerns. I enabled "virtual servers" for the Redis and Mongo ports on the router and it worked. – Reed G. Law Jun 14 '11 at 20:09

Lookup the record for the hostname, it could point to a public IP address in which case you'll likely be routed out your LAN's public interface rather than going internally, in which case you'd need to update your mysql.user table to allow access to the user from your public IP.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.