Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I recently purchased RHEL v6 so I was able to get entitlements on my recently upgraded RHEL v4 machine to v5 (v6 is down the road currently).

However, in the web interface I run the updates, it fails as it just shows pending with the stopwatch icon. If I run rhn_check the stop watch icon disappears and goes back to not installed. If I login using rhn_register it says the system is already setup for updates but it won't update. After doing an update from the website, I ran rhn_check -vv and got this as my results:

[root@intranet ~]# rhn_check -vv
D: check_action {'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>errata.update</methodName>\n<params>\n<param>\n<value><array><data>\n<value><int>11632</int></value>\n</data></array></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 203338917}
updating login info
logging into up2date server
successfully retrieved authentication token from up2date server
D: logininfo: {'X-RHN-Server-Id': xxx, 'X-RHN-Auth-Server-Time': '1308081188.41', 'X-RHN-Auth': 'xxx', 'X-RHN-Auth-Channels': [['rhel-i386-server-5', '20110613025406', '1', '1']], 'X-RHN-Auth-User-Id': '', 'X-RHN-Auth-Expire-Offset': '3600.0'}
D: handle_action {'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>errata.update</methodName>\n<params>\n<param>\n<value><array><data>\n<value><int>11632</int></value>\n</data></array></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 203338917}
D: handle_action actionid = 203338917, version = 2
D: do_call errata.update ([11632],)
D: Called update [['perl', 0, 0, '']]
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
D: Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 37017186
D: Sending back response ((6,), 'Error while executing packages action: Refusing to automatically import keys when running unattended.\nUse "-y" to override.', {})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or package list recently updated)', {})
share|improve this question

2 Answers 2

up vote 0 down vote accepted

A quick Google search yielded numerous results. Google search for redhat Use "-y" to override

The first response was: yum-rhn-plugin bug fix update. Take a look at it. It may help you.

share|improve this answer
    
I did that Google search as well, though it seemed that a handful of updates went through not all, but I think it does resolve the -y problem I been having. I think my questions had been answered. –  Jon Weinraub Jun 15 '11 at 13:51
    
well i was wrong, every update failed again... Error while executing packages action: Error Downloading Packages: subversion-1.6.11-7.el5_6.4.i386: failed to retrieve getPackage/subversion-1.6.11-7.el5_6.4.i386.rpm from rhel-i386-server-5 error was [Errno 4] IOError: neon-0.25.5-10.el5_4.1.i386: failed to retrieve getPackage/neon-0.25.5-10.el5_4.1.i386.rpm from rhel-i386-server-5 error was [Errno 4] IOError: [[6]] –  Jon Weinraub Jun 15 '11 at 20:53
    
it seems it isn't my network as i tried with two different T1s (different ISPs) and both are failing. i will try to contact redhat again but what makes no sense is, i had two individual updates that did succeed but not sure why these are failing. –  Jon Weinraub Jun 16 '11 at 14:39

D: Sending back response ((6,), 'Error while executing packages action: Refusing to automatically import keys when running unattended.\nUse "-y" to override.', {})

this kinda points to the issue. But in any case, if you have RHN then you should have support. Why ask on a forum when you can ask Red Hat?

share|improve this answer
    
how do I add the -y to override? I am using the web interface. I asked here because I don't have full support, just updates. I already opened up a ticket with redhat but customer service said I need to have paid support which my company lacks. –  Jon Weinraub Jun 14 '11 at 20:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.