Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I installed MoinMoin on Ubuntu 11.04 using the instructions in http://moinmo.in/HowTo/UbuntuQuick, including the (first two) bullets for Ubuntu 10.10 in the Suggestions section at the bottom.

Apache and MoinMoin are running on a machine at my employer with the hostname "daryls". (Only visible behind the firewall, of course.) So http://daryls/ goes to MyStartingPage.

When I click on HelpOnEditing and HelpOnMoinWikiSyntax while editing a page, I get a blank page. HelpContents (when I click on the HelpContents tab) is also blank.

I found a question in MoinMoin's documentation where a similar problem to mine is described. But clicking on HelpOnEditing goes to http://daryls/HelpOnEditing, HelpOnMoinWikiSyntax to http://daryls/HelpOnMoinWikiSyntax and HelpContents goes to http://daryls/HelpContents. (I don't have the extra "/instance_name/" in the URL as they describe.) But just to be sure, I cleared the contents of /usr/share/moin/data/cache, which made no difference.

I too wonder (like "twm" in the question) whether this is a configuration error. Do I need to tell MoinMoin or Apache that the domain name of the server is "daryls"?

share|improve this question
    
FYI I previously posted this same question to the moin-user mailing list: sourceforge.net/mailarchive/… –  Daryl Spitzer Jun 14 '11 at 20:27

1 Answer 1

up vote 5 down vote accepted

I didn't follow the instructions in section 3.3 of http://moinmo.in/HowTo/UbuntuQuick. It all works now that I have installed "all_pages".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.