Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to connect to a Hyper-v server on our network using the Hyper-V Manager. Others on the same network have this working, but when I try to connect to the same server, I just get this text in the Virtual Machines section.

Access Denied. Unable to establish communication between 'HYPERVSERVER' and 'MYCOMPUTER'.

What can be wrong here? My network administrator doesn't understand what's wrong. He has tried to give me access to the server, but this is obviously not enough.

share|improve this question
up vote 2 down vote accepted

Take a look at the Hyper-V Remote Management Configuration Utility. Written by John Howard from the MS Hyper-V team.

share|improve this answer
This is indeed a good reference. The others in my team has also used this tool to set up the system, but with help from my coworkers on this, it is still not working. – awe Jun 16 '11 at 12:49
I ran this command: cscript hvremote.wsf /show /target:HYPERSERVER, which reported a problem. One of the suggestions to fix the problem was to restart the Hyper-V server. We tried this, and now it works. – awe Jun 17 '11 at 6:17

Usually this is because Windows Vista/7 default DCOM does not allow connections from the outside. To enable follow these steps:

  • Run "DCOMCNFG"
  • Expand Component Services Computers My Computer > >.
  • Open the properties of My Computer and select the COM Security Tab.
  • In the Access Permissions section, click Edit Limits.
  • Select ANONYMOUS LOGON and check the Allow for Remote Access permission
  • Reopen the Hyper-V Manager and you should be able to administer the Hyper-V server
share|improve this answer
Sorry, I have done this now, but no luck. – awe Jun 16 '11 at 10:29
"cscript hvremote.wsf /anondcom:grant" does this for you... – Peter Ritchie Dec 22 '11 at 18:30
Yes and it doesmore too. it just requires more permissions and takes longer. – Jim B Dec 22 '11 at 21:39

Have your tried via IP address or FQDN as alternatives? You might verify that your DNS and/or WINS configurations match up to the other working systems.

share|improve this answer
I tried to add the server with IP address, and it automatically resolved to the server name, so this is not the issue. – awe Jun 16 '11 at 12:46
And you can ping and/or map successfully as well? – user48838 Jun 16 '11 at 13:07

if you are an admin on the remote computer then your problem is most likely network/firewall related

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.