Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Currently getting to grips with Web Farm Framewor and ARR. The Primary and Secondary servers are syncing from Primary to Secondary as they should be. However, there is a cache folder that is being synced which in turn causes the Secondary server to become unhealthy.

So was hoping somebody could explain how to exclude folders from syncing between the 2 servers if possible.

Cheers Jamie

share|improve this question

Try this page

To exclude folders from provisioning

  1. On the controller machine, open the ApplicationHost.config file. This is under the directory %windir%\System\inetsrv\config.

  2. Under the applicationProvision element, add an entry to skip the directives as follows

        <webFarm serverAutoStart="false" name="Farm"
            <server address="demo-primary" enabled="true" />
            <server address="demo-secondary" enabled="true" />
            <platformProvision syncPlatformFromPrimary="true" />
            <applicationProvision syncWebServerFromPrimary="true">
                    <skip name="folder1" skipDirective="objectName=dirPath,absolutePath=.*folder1.*" />

  3. When you save the changes, Web Farms Framework immediately picks up the changes from the configuration file and does application provisioning.

  4. Verify that the secondary servers provisioned only Folder2, and Folder1 was excluded.

  5. You can also skip binding as follows:
    <skip name="folder1" skipDirective="attributes.protocol=https" />

  6. Alternatively, you can sync a specific directory using the msdeploy command directly for each secondary server as follows:

    C:\>cmd.exe /c ""%ProgramFiles%\IIS\Microsoft Web
    Deploy\msdeploy.exe" -verb:sync
    -source:contentPath="Default Web Site",computerName=demo-primary
    -dest:contentPath="Default Web Site" -skip:objectName=dirPath,absolutePath=.*folder1.*"
share|improve this answer
@Antino - Welcome to Server Fault! Just a tip, it's generally a good idea to include the important excerpt from the page you've linked to, as links on the internet go dead all the time (esp. links from as they seem to re-structure their URLs all the time). I've added it in for you. – Mark Henderson Jul 1 '11 at 3:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.