Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question is related to a previous one on OSPF routing.

Based on the advice give to the previous question, I have now made myself a network diagram, identified the backbone area and all other areas and started configuring OSPF on the various routers. All the HP ProCurve 7102dl routers talk to each and that works fine. However, on the intra-area routers, which are all Linux servers, I am using quagga (Version 0.99.10, from debian lenny) and this just won't work at all.

Here are some examples: In one particular area the primary network is and both the linux router and the HP router have an interface in that network. The HP router has VPN tunnels to other HP routers and connects the entire subnet to the outside world. Behind the Linux router is another subnet on When I look at the OSPF configuration for these interfaces, this is what I get:

Linux router:

uk-swa-bps01# show ip ospf interface eth0
eth0 is up
  ifindex 2, MTU 1500 bytes, BW 0 Kbit <UP,BROADCAST,RUNNING,MULTICAST>
  Internet Address, Broadcast, Area
  MTU mismatch detection:enabled
  Router ID, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID), Interface Address
  No backup designated router on this network
  Multicast group memberships: OSPFAllRouters OSPFDesignatedRouters
  Timer intervals configured, Hello 10s, Dead 40s, Wait 40s, Retransmit 5
    Hello due in 6.595s
  Neighbor Count is 0, Adjacent neighbor count is 0

uk-swa-bps01# show ip ospf database
   OSPF Router with ID (

            Router Link States (Area

    Link ID         ADV Router      Age  Seq#       CkSum  Link count    1335 0x80000016 0xabf6 2

And on the HP router:

bps-test-vpn#show ip ospf interface ethernet 0/2
eth 0/2 is UP, line protocol is UP
  IP address:, Area:
  Router ID:, Network type: Broadcast, Cost: 1
  Transmit delay: 1, State: DR, Priority: 1
  Designated Router (ID):, Interface Address:
  Backup Designated Router (ID):, Interface Address:
  Timer intervals: Hello: 10, Dead: 40, Retransmit: 5
    Hello due in: 00:00:05
  Number of neighbors: 0, Adjacent neighbors: 0

bps-test-vpn#show ip ospf 0 database 

OSPF router with ID:

  Router Link States, Area 0
    Link ID          Adv Router        Age     Seq #         Checksum          601    0x80000004    0xECAD       1526    0x80000086    0xAAE1         826    0x8000009A    0x56EF     819    0x8000001D    0x0B13

  Summary Net Link States, Area 0
    Link ID          Adv Router        Age     Seq #         Checksum          825    0x80000001    0x2867       1520    0x80000001    0x3990        1226    0x80000009    0x4989        1226    0x80000032    0xD9D1     824    0x80000016    0xF915
bps-test-vpn#show ip ospf database 

OSPF router with ID:

  Router Link States, Area
    Link ID          Adv Router        Age     Seq #         Checksum     845    0x80000009    0xFD79

  Summary Net Link States, Area
    Link ID          Adv Router        Age     Seq #         Checksum     610    0x80000005    0x15AA     835    0x80000001    0x87FF     830    0x80000001    0x6919     835    0x80000001    0x0F6C     844    0x80000001    0x3C2C     835    0x80000001    0x1E45     830    0x80000001    0xA269     830    0x80000001    0x34CC     830    0x80000001    0x17EB

Clearly OSPF is enabled on both sides on the interfaces that are in the subnet, yet they don't talk to each other, because otherwise I would be getting some OSPF routes on the Linux Box. But I am not. So what am I doing wrong? I have tried all sorts of things, but I am not making any headways. Any advice would be appreciated. If you need additional info, just ask and I'll edit my post.

share|improve this question
The fact that neighbors: 0 is on both sides, and each thinks it is the DR indicates a very basic problem handling OSPF hellos. You should ensure that you can see OSPF hellos on both sides. – Mike Pennington Jun 15 '11 at 17:18
Are you still having a problem with this? If not, please post your solution... – Mike Pennington Jun 17 '11 at 17:52
I used the debugging features to establish that the problem was that one side saw the area as a stub and the other didn't. Once I fixed that, it all started working. Should I post this as an answer? – wolfgangsz Jun 17 '11 at 18:55
I can't accept my own answer, so really what's the point? – wolfgangsz Jun 17 '11 at 20:47
If you can't accept your own answer, how did I do it here? – Mike Pennington Jun 18 '11 at 4:04
up vote 0 down vote accepted

Guacamole pointed me in the right direction. I did a bit of debugging on the ProCurve and in quagga and it emerged that one of them was seeing the area as a stub area, but the other saw it as a normal area, and that's where the communication broke down. Once I had both configured to see the area as the same, it all worked like a charm.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.