Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a brand new out of the box Dell PowerEdge T310 running SBS 2011. Our employees at our remote offices can't send emails to recipients outside of our own domain. The workstations at the same location as the server aren't having any problem.

I know this is something dealing with relaying but thus far nothing from any posts I've read have changed anything.

share|improve this question
    
Why are the remote users using POP and/or IMAP instead of Outlook Anywhere (RPC over HTTP)? –  joeqwerty Jun 15 '11 at 23:41
    
Outlook2007 and 2003 Your message did not reach some or all of the intended recipients. Subject: Test 1 Sent: 6/15/2011 7:44 PM The following recipient(s) cannot be reached: 'xxx@xxx.com' on 6/15/2011 7:44 PM 550 5.7.1 Unable to relay –  user779887 Jun 15 '11 at 23:44
    
@joe - Because they prefer to use the outlook client. –  user779887 Jun 15 '11 at 23:45
    
@joe - And because (I suspect due to the same obscure server setting I can't find) I've had even less success getting a successful Exchange connection set up on anyone's computer outside the office. I was able to connect my laptop is minutes and I have a reliable email connection from anywhere without any problems. But collecting all of the workstations and ferrying them to the office and back from 3 locations hours apart from each other didn't seem like a sensible option in the beginning... –  user779887 Jun 15 '11 at 23:53
    
The Outlook client is the client for use with Outlook Anywhere so the users don't need to change email clients. I understand about not wanting to go through the exercise of rallying all of the laptops together, but OA is a better solution all the way around. –  joeqwerty Jun 16 '11 at 0:13
show 3 more comments

3 Answers 3

Instead of creating a new Receive Connector in the Hub Transport in the Exchange Management Console, modify the Default Receive Connector with the following settings:

  • Network: Make sure the IP addresses where you receive mail from are included in the "Receive mail from remote servers that have theses IP addreses"
  • Authentication: check "Transport Layer Security" and "Externally Secured"
  • Permission Group: Not sure about the requiremets, but I have everything but "Partners"

Watch out that you are not making an open relay. Restrict incomming IP addreses in the Network tab or in your firewall.

I was struggling with the same issue a month ago, and wasn't able to get it working with the instruction on petri.co.il and otherwhere where the instruction was to create a new Receive Connector.

share|improve this answer
add comment

Please make sure you restart the Microsoft Exchange Hub Transport when making those changes. not the Store.

share|improve this answer
add comment

The problem isn't on the client it's on the server. You need to configure a Recieve Connector that will allow authenticated relaying from external ip addresses.

That's why I was suggesting in my comments that you configure the clients to use Outlook Anywhere as that will allow you to avoid all of the hassle of getting the server and clients configured correctly and securely for POP/IMAP.

In SBS, all of the work of getting the server configured for OA is done as part of the installation/configuration. The only thing left to do on your part is to get a proper SSL certificate, configure your firewall appropriately, and configuring the clients.

share|improve this answer
    
Outlook Anywhere won't work. I tried entering the settings that are working on my laptop into two of the remote workstations. They both claim that they can't connect or find the exchange server. The only difference is that my laptop has Office 2007 and their has Office 2003. –  user779887 Jun 16 '11 at 2:09
    
I tried several posts illustrating how to create a Receive Connector. Each time it completed successfully but there was absolutely no change in the result. I even tried restarting the exchange store each time but no effect. Always Error 550 5.1.7. If you have a link to a tutorial for this that you believe works, post it and I will attempt it again. –  user779887 Jun 16 '11 at 2:11
    
I tried this one: lazynetworkadmin.com/knowledgebase-mainmenu-6/2-windows/… –  user779887 Jun 16 '11 at 2:12
    
I tried this one also petri.co.il/… –  user779887 Jun 16 '11 at 2:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.