Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are currently facing a serious problem after we rolled out Windows 7 in our sales force: Several users reported that they cannot log into their laptop because the following message appears:

There are currently no logon servers available to service the logon request

In fact, these laptops are connected to a domain. After the user is logging in, he usually establishes a VPN tunnel to our servers. Normally the domain account is being cached on the users PC so he is able to log in offline initially to create a VPN tunnel afterwards.

A known workaround is to connect the laptop directly to the LAN or to remove the client from the active directory and add him again.

Do you have any tips how we could handle this issue without the need to send the laptop to the IT?

share|improve this question

6 Answers 6

Your wording suggests that perhaps those users have never logged on to those laptops while the laptops were connected to the network. In such a case their credentials have not yet been cached. The laptops must be able to communicate with the domain controller for at least one login per account.

share|improve this answer
    
Sorry that I wasn't able to answer for a while. They were able to connect via VPN once but still got this message after the next boot up. –  aydinch Jun 20 '11 at 6:57
1  
@aydinch, in order to initially create the domain account profile they must be connected to the domain BEFORE logging in. I suspect that's no what's happening. It's worth noting that most of us would normally configure laptops and perform the initial log on while said laptop is connected to the LAN in order to avoid the issues you are experiencing. –  John Gardeniers Jun 20 '11 at 8:00

Have a look to see if you can't launch the VPN tunnel before user login, that would be the best solution.

Also doublecheck DNS settings: is the default DNS server the same as (or trusted by) the login/domain server?

And what OS version is running on the login/domain server?

share|improve this answer
    
Hi, unfortunately it is not possible for me to esablish a VPN tunnel without logging in with the users account. The DNS settings are also OK but this couldn't be the problem since the DNS settings are provided by the ISP unless the user is already connected via VPN (which is the problem here) –  aydinch Jun 20 '11 at 7:03

Firstly when you are setting up the VPN connection on the laptop, ensure that all users can use it. Next log off Win7. At the logon screen select switch user. Now you will see another logon option in the bottom right of screen. (Network login (Icon is 2PC's one behind the other and slightly offset)). Select this and your default VPN login dialog should appear. Sign in and the VPN connection will initiate prior to Windows login. Should you have more than one VPN connection, select the one you wist to initiate.

share|improve this answer

Windows 7 is booting too fast on new computers. Windows get's to the logon screen before the network binding process is finished. In addition to Leo's advice: "If the issue persists, you can check “Always wait for the network at computer startup and logon” policy is disable under Computer Configuration/Administrative Templates/System/Logon in the Group Policy." http://techdom.nl/microsoft/disabling-domain-logon-wait-time-when-no-domain-controller-available/ Computer Configuration > Administrative Templates > System > User Profiles > Set Maximum wait time for the network if a user has a roaming user profile or remote home directory.

share|improve this answer

I have had the exactly the same problem in my question here, hopefully some of the answers will help you. I noticed that removing and re-joining to the domain does work.

So far been unable to nail down the exact cause, however.

share|improve this answer
    
We were unable to solve the problem, too. We ended up connecting these laptops to the on-site local area network. –  aydinch Jun 20 '11 at 7:04
up vote 0 down vote accepted

finally we found the problem cause!

The users suffering from the described problem recently called because of another application issue. The common workaround for this issue was to start IE as admin and delete a specific Add-On. The next time the user rebooted his machine, he got the message:

There are currently no logon servers available to service the logon request

Conclusion: Only one user at a time can be cached(?) This means that we are not allowed to run IE as admin. We were able to "successfully" reproduce this issue.

share|improve this answer
2  
The default number of cached logons is 10, you may want to explore your Group Policy configuration to see if this has been changed. –  jscott Jun 20 '11 at 11:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.