Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed a headless VMware server on my Linux Debian server.

For some reason I cannot connect to the web management console on port 8333. However, if I port forward localhost via ssh to the remote server (and set Firefox up to use the proxy), I can connect to the management console without problems. Using this approach I have succesfully started the virtual machine.

I can also telnet to vmware server on port 8333 when logged in on the remote server.

When I run a vmware status command, I see this message among others:

Host network detection is not running

I am not sure if this has something to do with the problem, though.

I have tried both

/etc/init.d/vmware-mgmt restart


/etc/init.d/vmware restart

but that doesn't make any difference.

As far as I know, there is no firewall on the server, but to be honest I am not completely sure how to check this!

Thanks in advance for any hints that might help me solve the problem :)


This is the result of netstat:

netstat -anp | grep :8333
tcp        0      0  *               LISTEN      12850/vmware-hostd
share|improve this question
I have removed your VMware tag as VMware is a company who make a number of virtualization products. Please consider adding a product specific tag which can be found as vmware-product. – Iain Jun 17 '11 at 17:04
Thanks for the clarification. – marlar Jun 17 '11 at 19:59

Did you try stopping the services, running a ps aux and grepping for `vm to make sure all of the processes died, then starting the daemons again? Also, are you using https to connect to the web console?

share|improve this answer
I just tried now to no avail. And yes, I am using https. – marlar Jun 16 '11 at 23:03
up vote 0 down vote accepted

What I didn't know was the host company had a hardware firewall which had to be opened as well. I only checked the local iptables rules. Now it works correctly!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.