Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm taking backup of my database and it has text field which contains following content:

Original data: "Rock'n Roll"

Database backup: "Rock\'n Roll"

What it should be in backup: "Rock''n Roll"

So what could be causing this error in my MySQL configuration?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Unusable? Rock\'n Roll should be a perfectly valid form. Backslash is just an escape character telling MySQL that the following ' should be considered as data and not as SQL delimiter '.

Did you try actually restoring you backup?

share|improve this answer
    
yes and it fails –  newbie Jun 17 '11 at 9:06
    
And the error message is? –  Janne Pikkarainen Jun 17 '11 at 9:12
    
It returns "Unknown object in backup file" error in target linux system. Itake backup from Windows 7 32bit system. –  newbie Jun 17 '11 at 9:15
    
I tried to restore database in my Windows 7 and it worked, but exact same file gives that error in Linux. I use MySQL Admin over SSH to restore database in Linux. –  newbie Jun 17 '11 at 9:21
    
Problem was in MySQL admin, when I used mysql from command line in linux it worked. –  newbie Jun 17 '11 at 10:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.