Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have successfully configured OSPF on all of our HP ProCurve 7102 routers, and most of our internal Linux routers. Routes get advertised, and all is peachy.

Except for the routes into the subnets handled by various OpenVPN services and other VPN connections around the company. Please consider the picture below, which shows a part of the company network:

enter image description here

The red arrows are VPN connections. The blue area at the bottom depicts OSPF area 0 (the backbone), which comprises routers in all other offices. The pink area depicts OSPF area 177 for one of our offices. The orange rectangle is the OpenVPN network in question, hosted on the Linux router indicated by the blue icon with the arrows.

The 10.177.0.0/16 subnet is properly advertised to all other OSPF areas. However, despite the fact that network 10.180.1.0/24 is included in the OSPF configuration, and interface tun0 is included in area 177(as a passive interface), this subnet does not get advertised.

Is that because this is actually an external route? If so, how would I tell the OSPF daemon to advertise that route?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

The first thought that comes to mind is that you need to redistribute the kernel routes in addition to the connected routes in Quagga/Zebra OSPF. Because OpenVPN adds the routes itself, Zebra will not redistribute them if you only have 'redistribute static' in your configuration.

I am using OpenVPN in OSPF environments too, and everything redistributes just fine.

Note: you may need to add some redistribution list filters to prevent redistribution of other kernel routes that shouldn't be advertisted.

Another option is to add a static route in Zebra for the 10.180.1.0/24 going to null or the loopback device.

share|improve this answer
    
Gotcha. I suspected that the answer was right in front of my face. Now, moving on to the two networks of 192.168.85.x and 172.23.x.y. These are VPN connections into the HP router, but since they are not connected to a GRE tunnel, the router doesn't actually have any routes for these in its own routing tables. It simply picks up the packets and matches then against the various IKE/IPSec policies. How would I publish these? Also manual routing? –  wolfgangsz Jun 20 '11 at 14:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.