Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i was recentyly testing google spreadsheet api using Zend Framework, but Got this error

Uncaught exception 'Zend_Gdata_App_HttpException' with message 'Unable to Connect to ssl://www.google.com:443. Error #148105208: Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP?' in ....

I am using Xampp 1.7.4 , i have checked httpd.conf, mod_ssl.so is enabled there. please help

share|improve this question
1  
Possibly dumb question, but are you sure you use ssl://www.google.com:443 rather than just https://www.google.com? –  Ben Pilbrow Jun 18 '11 at 10:40
    
This was the unmodified part of the error i get from zend framework . i think https works using ssl protocol, –  user80287 Jun 19 '11 at 16:25

1 Answer 1

up vote 1 down vote accepted

The error message appears to be related to the php ssl module, not apache. You can check what modules are enabled by running php -m. Look for an openssl line.

If it is not enabled you can enable it in your php.ini file by adding the line:

extension=php_openssl.so

The above applies to linux, on windows you would use:

extension=php_openssl.dll

It may be that this line is commented out in your XAMPP installation.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.