Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install Sql Server 2008 R2 Express(x86) to my Windows Server 2008 Server(32bit) machine since yesterday evening but I am having this weird error during installation progress. "1% is not a valid win32 application" I have uninstalled and reinstalled times and times but no luck. Also I have tried to install with Web Platform Installer. What can be the problem and how can I install this thing to my server?

share|improve this question
If you absolutely sure that you have downloaded the right version (not x64) then verify the download size, and make sure that your download is not corrupted -- this most likely to be the case. If size looks the same, try re-downloading it again but make sure you have cleared the browser cache. –  LazyOne Jun 19 '11 at 9:25
there are 2 files of x86 on microsft's site. SQLEXPR_x86_ENU.exe and SQLEXPR32_x86_ENU.exe. Which one should I download? –  zforx Jun 19 '11 at 9:27
Should be not difference as long as your OS is definitely 32-bit only. "SQLEXPR32_x86 is a smaller package that can be used to install SQL Server 2008 R2 Express onto only 32-bit operating systems. SQLEXPR_x86 is the same product but supports installation onto both 32-bit and 64-bit (WoW) operating systems." I would go with SQLEXPR_x86_ENU.exe, but if that is one that gives you troubles then go with SQLEXPR32_x86_ENU.exe. –  LazyOne Jun 19 '11 at 9:38
I have tried both but no luck. I think there is something different is causing the problem because Web Platform Installer cannot install too. –  zforx Jun 19 '11 at 9:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.