Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed a package into my own debian package repository like so:

$ sudo reprepro -b /var/packages/ubuntu includedeb maverick my-package_0.8-0_all.deb 
my-package_0.8-0_all.deb: component guessed as 'main'
Exporting indices...

I have installed my package on a few machines using apt-get install.

I have now added new features to my software and would like to add a new minor version of my package to the repository so that I may update my machines using apt-get upgrade.

I try to do this like so:

$ sudo reprepro -b /var/packages/ubuntu includedeb maverick my-package_0.9-0_all.deb 
my-package_0.9-0_all.deb: component guessed as 'main'
Skipping inclusion of 'my-package' '1.0-0' in 'maverick|main|i386', as it has already '1.0-0'.
Skipping inclusion of 'my-package' '1.0-0' in 'maverick|main|amd64', as it has already '1.0-0'.

It looks like I need to tell reprepro that this is a new version of the same package but I have no idea how to do this. I have read the reprepro man page several times and searched on the net for a couple of hours but I have not found any answers.

Am I missing something?

Many thanks.

share|improve this question

2 Answers 2

When you build your dpkg, you should increment the package version as per here.

The Debian Revision Number (the -xxx at the end of packages) is the one you should increment.

share|improve this answer
    
Thanks for your suggestion but changing the number at the end of the package did not help my problem. I tried first adding a package my-package_1.0-0_all.deb and then my-package_1.0-1_all.deb but got exactly the same error as above saying that it already has 1.0-0. –  kai Jun 20 '11 at 20:43
    
Dropping the _all also made no difference. –  kai Jun 20 '11 at 20:52
    
what's the "skipping inclusion" line when you try to add your new package version? –  Michael Lowman Jun 21 '11 at 3:27
    
The skipping inclusion line is where reprepro is trying to add my-package_0.9-0_all.deb as version 1.0-0 and finding that it is already in the repository. I would really like to be able to tell reprepro that this is a new version of an existing package! That is my problem. –  kai Jun 21 '11 at 7:41
    
When you say "Changing the number at the end", do you mean changing the file name or editing the version number in the control file? –  theotherreceive Jun 21 '11 at 9:27
up vote 4 down vote accepted

Reprepro is not able to hold two versions of a package in the same distribution.

See answer to question 3.1 here: http://anonscm.debian.org/gitweb/?p=mirrorer/reprepro.git;a=blob_plain;f=docs/FAQ;hb=HEAD

share|improve this answer
    
If this is your answer, you should mark it accepted. and welcome to serverfault :) –  Michael Lowman Jun 21 '11 at 13:56
    
Dead link as of 11/15/13. –  Joe Nov 15 '13 at 14:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.