Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've turned on sticksessions in apache. Config is at:

The logs show apache finding the cookie but it still doesn't remain sticky to one of the servers in the balancer. Filtered log is:

share|improve this question
up vote 0 down vote accepted

Your JSESSIONID cookies don't appear to contain a route, just the session ID.

They need to provide that information in their cookies in order for Apache to know what member to send to; such as 771F23205D79E225993EDC2FD884A5C6.nfl1.

What's the back-end web service? It'll be a setting there, if it supports it. Alternatively, you can have Apache set a cookie directly for tracking the stickiness, avoiding the need to use the back-end's session ID. Info on doing that here.

share|improve this answer
jboss is the back end.The ever so modern 4.0.5 version. Digging some more. Thanks – Tracy Snell Jun 20 '11 at 19:20
Should be able to set a jvmRoute in the <Engine> config. – Shane Madden Jun 20 '11 at 19:24
All set! Thanks. – Tracy Snell Jun 20 '11 at 20:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.