Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a site running PHP 5.3.2 + PHP-FPM and Nginx 0.7.65 and rebooted the server after changing the root password. The web server starts up fine, but the site doesn't come up and the only clue I have is in the web application's log (from Predis, specifically):

/home/myapp/dev/releases/20110520160839/components/Predis/Predis.php(1250): Predis\TcpConnection->w in /home/myapp/dev/releases/20110520160839/components/Predis/Predis.php on line 1259" while reading response header from upstream, client: 69.X.X.X, server: dev.example.com, request: "GET / HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "dev.example.com"

It seems the connection is refused on port 9000 for FastCGI. When I run "nmap 127.0.0.1" I don't see anything for port 9000.

"netstat -ntlp" does show this, though:

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:4949            0.0.0.0:*               LISTEN      1169/munin-node 
tcp        0      0 0.0.0.0:21              0.0.0.0:*               LISTEN      1089/vsftpd     
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      985/sshd        
tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN      1076/master     
tcp        0      0 127.0.0.1:9000          0.0.0.0:*               LISTEN      2309/php5-fpm   
tcp        0      0 0.0.0.0:10000           0.0.0.0:*               LISTEN      1297/perl       
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      1272/nginx      
tcp6       0      0 :::22                   :::*                    LISTEN      985/sshd

And this is interesting:

# lsof -i tcp:9000
COMMAND   PID    USER   FD   TYPE DEVICE SIZE NODE NAME
php5-fpm 1331    root    6u  IPv4   4810       TCP localhost:9000 (LISTEN)
php5-fpm 1332 theuser    0u  IPv4   4810       TCP localhost:9000 (LISTEN)
php5-fpm 1333 theuser    0u  IPv4   4810       TCP localhost:9000 (LISTEN)
php5-fpm 1334 theuser    0u  IPv4   4810       TCP localhost:9000 (LISTEN)
php5-fpm 1335 theuser    0u  IPv4   4810       TCP localhost:9000 (LISTEN)
... 20 more lines like that ...

Can someone help me narrow down where the problem is here?

share|improve this question
    
Nevermind, we fixed it by restarting redis (/etc/init.d/redis restart). Apparently it was not set to start along with nginx and php5-fpm on boot. –  Devin Jun 21 '11 at 2:31
    
What is the relation of Redis [key-value db] to the network problem? –  Shehi Jul 11 '11 at 0:32
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.