Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My hosting provider has supplied me with global static IPv6 for my machine. It appears that auto configuration has been successful and I can successfully ping my machine and tracepath6 appears to function correctly. I am running a 64bit Arch Linux distro.

However I am unable to ping any ipv6 device from the machine and all traceroutes fail at the auto configured link local router address.

How would you further troubleshoot this issue?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

I've seeen this when the device has the wrong subnet length specified (/64 when it should be /48) etc.

share|improve this answer
    
Spot on! After changing my static configurations to utilized a 48 bit mask communication has resumed. Strange in that my provider provisioned the addressing details. –  Ben Campbell Jun 21 '11 at 5:29
    
@benji - had the same issue with an ipv6 provider myself yesterday. They gave me a prefix length of /64 in the documentation, but it was actually a /48. These things are bound to happen during teething for early adopters. –  Mark Henderson Jun 21 '11 at 7:54

Just a quick thing to check ... your running ping6 right (instead of ping).

Has your computer received a Global IPv6 address in addition to the local address? Double check that.

Otherwise, check to make sure your machine has received a default route. It's 'ip route -6' I think. I have one router that sends screwed up router advertisements so Linux will properly add the address to the interface but not set it as a default route. Can you ping6 your default route?

Otherwise, what machine are you pinging? What is the exact error?

share|improve this answer
    
My interface is configured both with a local and global IPv6 address. Like I mentioned my machine responds to pings from external devices, however cannot ping external devices. I am pinging ipv6.google.com. I get a host not reachable from my link local configured gateway. From fe80::2d0:4ff:fefd:5c00 icmp_seq=3 Destination unreachable: Beyond scope of source address –  Ben Campbell Jun 21 '11 at 5:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.