Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have just installed our new Spam Firewall, and all seemed well. But the Spam Firewall has now decided to put all mail in a message queue and I have no idea how to force it on or anything as there doesn't appear to be anything on the GUI to manage the queue, there is no documentation on the queue, and the support don't want to call me back.

Any ideas?

share|improve this question
    
Do you have it installed in a windows AD? Is LDAP setup correctly? is it tied to your mail server correctly? If mail is coming into the filter and the filter can't figure out who the mail is going to, it'll stack up. we've had this happen before when the 'connectin' between our exchange server and the filter went south. –  RateControl Jun 18 '09 at 18:29
    
Yes and the test was 100% successful, it was forwarding all the mail to exchange and then onto the user but then stopped for some strange reason. Anyway it WAS building up but has now since gone through to Exchange and the mailboxes. But and there always is, it's not registering its sent any mail or updating the statistics. I should also point out it's a trail kit that we've had for nearly 2 weeks if that would have any implications? –  stead1984 Jun 18 '09 at 18:53
1  
The fact that it is a trial may be why support isn't calling you back. Call your sales rep and try to get support's attention that way. Point out that if the box isn't working, you're not likely to buy one. –  David Mackintosh Jun 18 '09 at 19:58
add comment

4 Answers

It looks like version 4.x of the new firmware supports this feature (now in early release mode).

From the 4.0.0.035 release notes:

New 'Retry' button - For mail that is waiting in the Out queue, clicking the Retry button on the BASIC > Administration page initiates the process to retry sending the messages immediately.

share|improve this answer
add comment

Another quick (temp) solutions are:

1) reloading your config (no downtime) or to reboot your device (= downtime).

The reload can be performed from the basic -administration section. Reloading will also refresh your webgui connection during approximately 10 - 15 seconds.

2) removing message which is stuck in the queue.

Call support to let them check your appliance health / find the real problem (to many SPAM messages received / message stuck, hardware error, etc)

share|improve this answer
add comment

We feel your pain. From what I understand, the Barracuda's internal applications are not multi-threaded (so each inbound email is scanned in sequence) and from our experience, when it is processing an email with an attachment, the queue appears to be "clogged" for awhile. We have since dumped our Barracuda in favor of a hosted solution from another provider.

share|improve this answer
add comment
up vote 0 down vote accepted

After 2 hours onto Barracuda and a further hour on a support tunnel, it seems that they just restarted the message queue service, which I must add I couldn't find so must be command line. Once I hear back from support I will comment to this answer with the command itself.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.