Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When my OpenVPN session is on, I'm able to establish VNC sessions on other computers. Just this particular computer which I can't seem to figure out why.

Here are some methods I've tried

  • Turn of firewall completely
  • Look at log files
  • Close any apps which might be using the VNC port
  • Used alternative VNC software - Currently using RealVNC, tried TightVNC, but still the same

Any other methods I should use to find the root of the problem?

share|improve this question
Can you access any other service? Have you tried telnet? – ghm1014 Jun 21 '11 at 17:56
@ghm1014 just tried ftp and telet. similar situation. they work over the local network but not over the VPN. – tom Jun 22 '11 at 17:39
I've determined that the OpenVPN connection is causing all the problems on that computer. even after I've turn off the firewall, I still can't reach that computer with a OpenVPN connection. – tom Jun 27 '11 at 18:35

Have you queried the route table while the VPN is active? If so, is there a route to the other systems? Or at lease a default route to the VPN server (which should then have a route to the other systems, in that case)?

share|improve this answer
Do you mean the route table in the computer that is not working. If you mean that, yes, I've checked, there is no route to the VPN server. However, the other computer which I'm able to VNC into do not have a route table entry too. – tom Jun 22 '11 at 17:41
"However, the other computer which I'm able to VNC into do not have a route table entry too." What are the IP configurations of those systems? – user48838 Jun 22 '11 at 18:07
@user48838 Do you mean static or DHCP? If so, they are configured static. LAN OpenVPN: – tom Jun 27 '11 at 9:28
The computer that has the problem has two active ethernet ports. However, I made sure I disabled one to make sure the 2nd ethernet port is not causing the problem. – tom Jun 27 '11 at 9:31
What is the IP configuration of the troublesome system vs. that of the OpenVPN server? Can the system be reached from the OpenVPN server? – user48838 Jun 27 '11 at 12:37

I've solved the problem. All I had to do with adding a route back to the OpenVPN server into the route table.

Although I still do not understand why not all hosts require the route to be added in order for VPN, FTP. Telnet, etc. sessions to be established.

share|improve this answer
It looks like you have at least two networks on your LAN ( & where your OpenVPN session may have only pushed one network route ( out to the remote client. – user48838 Jun 29 '11 at 7:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.