Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Given the following backup sets ...

Found primary backup chain with matching signature chain:
-------------------------
Chain start time: Tue Jun 21 11:27:26 2011
Chain end time: Tue Jun 21 11:27:59 2011
Number of contained backup sets: 2
Total number of contained volumes: 2
Type of backup set:                            Time:      Num volumes:
     Full         Tue Jun 21 11:27:26 2011                 1
     Incremental         Tue Jun 21 11:27:59 2011                 1

If i run the following command, it works (1308655646 was converted from Tue Jun 21 11:27:26 2011):

duplicity --no-encryption --restore-time 1308655646 --file-to-restore ORIG_FILE \
file:///storage/test/ restored-file.txt

However, if I run the following command, it restores the from the latest set.

duplicity --no-encryption --restore-time 2011-06-21T11:27:26 --file-to-restore \
ORIG_FILE file:///storage/test/ restored-file.txt

What am I doing wrong w/ the time? I prefer the second option only because I don't want to have to do the conversion manually.

Also, I noticed the filenames have a different timestamp...

duplicity-inc.20110621T172520Z.to.20110621T172537Z.manifest
duplicity-full.20110621T172520Z.vol1.difftar.gz
share|improve this question

1 Answer 1

up vote 1 down vote accepted

1308655646 seconds since the epoch is 2011-06-21 11:27:26 UTC. 2011-06-21T11:27:26 is 11:27:26 in your timezone. I'll venture the guess that you live in the western hemisphere, so the date you specified was still in the future, and duplicity gave you the latest backup. Pass 2011-06-21T11:27:26Zor2011-06-21T11:27:26+00:00` to indicate a UTC date.

(I've just checked, and duplicity's time report uses the local time. Did you run it with a different timezone setting?)

share|improve this answer
    
yes, i've tried it with 2011-06-21T11:27:26-05:00 but I thought duplicity would use the default timezone if you don't specify a timezone. –  luckytaxi Jun 21 '11 at 18:28
    
Ok, I got it working. I was using the wrong timezone. I forgot we were in daylight savings time. –  luckytaxi Jun 21 '11 at 18:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.