Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I have looked everywhere for the solution to this and have tried many things. There is one post on SE related to this and I tried the suggested answer but I am still having problems.

We have a server running Server 2008 R2 Standard x64. I need to increase the space of C: since the free space is running very low. However when I open Server Manager and try to go to the "Disk Management" snap-in it just hangs.

There is a status message on the bottom of the window that says "Connecting to Virtual Disk Service...".

Here are the steps I have taken:

  1. Ran sfc /scannow
  2. Set all of the drives to be dirty and rebooted so that they would be scanned
  3. Executed chkdsk /f /r /b /v on all of the drives.
  4. Checked for Windows updates (none).
  5. Verified that the services "Virtual Disk", "RPC Procedures" and "Plug and Play" are all running.

One symptom is that the service "Virtual Disk" does not cleanly shut down. I receive a message about the process being unexpectedly terminated when I try to stop or restart it. Also I cannot find anything relevant in the event logs.

Any ideas or suggestions?

share|improve this question
I just found this in the event log, it is related to the unexpected termination of the virtual disk service: The Service Control Manager tried to take a corrective action (Restart the service) after the unexpected termination of the Virtual Disk service, but this action failed with the following error: An instance of the service is already running. – Payson Welch Jun 21 '11 at 18:14
Also windows server backup takes a very long time to initialize (around an hour) but it eventually does initialize – Payson Welch Jun 21 '11 at 18:18
What type of volumes do you have (disk vs SAN?)? – Matias Nino Jun 21 '11 at 19:01
We have two arrays both in Raid 1 using 2.5" sata drives. – Payson Welch Jun 21 '11 at 19:08
Are you doing RAID through hardware or windows? – Matias Nino Jun 21 '11 at 21:06

I seem to have fixed this. I re-ran chkdsk on C: (note that it appears you have to manually set this as dirty even if the system is scheduling the scan). I also uninstalled my ISO mounting software (virtual clone drive) even though I have never had a problem with it before. I also moved the page file to its own drive (I did this to free up space on C:). Also I uninstalled the Yosemite backup for Dell which had expired (perhaps because of the expiration it was no longer functioning and preventing the disk image service from doing what it needed to do?).

At any rate after uninstalling, freeing up disk space and running chkdsk, Disk Management is back online. I ultimately suspect it was Yosemite backup since I had had problems with it even running on this system. My best guess is that it installed a driver or piece of code that interfaces with the system / drives and because it had expired it was no longer functioning properly. This is pure speculation though.

share|improve this answer

Some things to try:

1) Make sure there are no other disk/volume management tools/services running (e.g. Disk imaging tools, defragging tools, backup tools). You can even be more aggressive and disable as many 3rd party services and auto-run programs as possible.

2) Make sure you have all the latest windows updates, including 2008 R2 SP1.

3) Install the latest drivers for all your storage controllers.

4) Run As Administrator

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.