Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have two Servers, Server X (IP 192.168.1.1) and Server Y (IP 192.168.1.2), both of them are ubuntu 9.1
i have created varnish load balancer on them for my drupal website (pressflow 6.22) I have mounted a directory of imagecache from server X to Y as below

@X:/etc/exports ==> /var/www/proj/htdocs/sites/default/files/images   192.168.1.2(rw,async,no_subtree_check)

@Y:/etc/fstab ==> 192.168.1.1:/var/www/proj/htdocs/sites/default/files/images    var/www/proj/htdocs/sites/default/files/images   nfs defaults    0       0

also i made this on server X

X:/var/www/proj/htdocs/sites/default/files$ chmod -R 777 images

i tried to touch, rm, vim, and cat> files in images directory that has been mounted on Y and everything went fine.
now, ALWAYS when server Y's imagecache tries to create an image in images directory, the image is created with ZERO byte file size.
anyone face the same before? any idea of how to fix this problem or what might cause it?
Thanks for your help

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Thanks All,
i have found the problem.
i should install the following packages on server Y in order to get imagecahe working fine:

advpng  
optipng   
jpegtran  
jfifremove
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.