Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using Backtrack on my virtual machine (Host: Windows 7).. Primarily, I'm having problems sending packets using Scapy..Using the send() and sendp() function, I'm only able to send crafted packets on the loopback interface. I need to send them wirelessly (I have got an external WLAN card of DLink).

When I use send() function, it says "sent x packets" but When I start my packet sniffer (Wireshark) on the same interface (monitor iface on wlan0), nothing gets captured.

Can anyone help identify the problem?

Thanks

share|improve this question

migrated from security.stackexchange.com Jun 21 '11 at 21:03

This question came from our site for Information security professionals.

    
not really a security question as such- if you don't get any useful answers here we can migrate this over to SO or somewhere more appropriate. –  Rory Alsop Jun 16 '11 at 12:59
    
@Rushil it would help if you could provide the actual command you use you create the packet that doesn't get sent. –  john Jun 16 '11 at 22:38
    
@john, I'm using backtrack on vmware and an external WLAN card, so i'm using "bridge mode", directly bridging my physical network onto I don't know what.. The commands are simple: ip = IP() ip.src = "192.168.1.5" ip.dst = "192.168.1.1" icmp = ICMP() icmp.type = 8 packet = ip/icmp send(packet, iface = "mon0") (I even tried "eth0") –  Rushil Jun 17 '11 at 12:36
    
and when i'm using NAT mode, packets are getting sent.. But I won't be using NAT in the long run, I don't want my Backtrack instance to share its IP addr with the host... Generally my ext. NIC will be working independently... –  Rushil Jun 17 '11 at 12:42
    
@john, I discovered something just now, when I send the packets in bridge mode on the monitor iface, they get sent on the ethernet interface.. And on capturing packets there, it shows "Malformed Packets".. Protocol LLC.. I don't know what's happening.. –  Rushil Jun 17 '11 at 12:49
show 4 more comments

1 Answer

Regarding your comment :

When I send a TCP syn packet to a server, a reply comes, and a TCP ack packet is automatically sent from me. I don't understand what application sends it from my side and why.

The application on your side which sent the TCP syn is also sending the TCP Ack.

This is the way the TCP handshake works :

client         server
  | -- tcp syn -> |
  | <- syn+ack -- |
  | -- tcp ack -> |

More informations on the wikipedia page about tcp.

Not sure how you solved the injection issue, but remember that injection is only possible with vmware when using usb cards. (I think that it must be shared as usb peripheral, and not "bridged network", but not sure about that).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.