Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to do a reset on IIS 6.0 from the command line and I get this message below, all the services are up and running, googled for a solution, tells me to reinstall IIS 6.0, which I tried so many times. Any idea what is the problem? Using windows server 2003.

Attempting stop...
Internet services successfully stopped
Attempting start...
Restart attempt failed.
IIS Admin Service or a service dependent on IIS Admin is not active.  It most likely failed to start, which may mean that it's disabled.
share|improve this question

migrated from stackoverflow.com Jun 22 '11 at 2:35

This question came from our site for professional and enthusiast programmers.

    
Ensure the IIS Admin service is running (and installed). –  Oded Jun 21 '11 at 19:33
    
i did verify the IIS ADMIN service and it always shows as running, even after iis reset fails. –  Natasha Thapa Jun 21 '11 at 19:37
1  
This would be better as a comment than an answer, but I don't have that privilege. Do you see any specific errors in the application or system logs? Try performing a stop/start in services.msc: Does it give you a more specific error? –  Gary Jun 22 '11 at 3:20
    
Are there error messages in the Application or System event logs related to W3SVC or IISADM? –  Jeff Jun 22 '11 at 10:16
    
no there are no errors in any eventvwr logs, i also tried to do logman but didn;t spit out anything that was useful. –  Natasha Thapa Jun 23 '11 at 18:36
add comment

1 Answer

up vote 0 down vote accepted

Multi-part answer:

0) You reinstalled IIS despite it working? Just as a safety note, reapply the latest SP and patch for it. Just in case the binary versions are out of whack.

1) Don't IISReset. Why are you IISResetting? Are you /NoForce ing it?

2) Have you identified whether any other services are stopped? WWW Publishing, FTP Publishing, SMTP Publishing, and so on? That'd be my guess as to what the error means.

share|improve this answer
    
no it was not working when i reinstalled. when i say its not working, i mean it would work but when you do issreset you would get the msg above.so i thought there must be a bigger problem here. to apply any changes i have made i do iisreset. no i am not doing /noForce no i have not checked otehr services, only service that is hossted on that IIS is WWW, so i will check than one now –  Natasha Thapa Jun 23 '11 at 18:39
    
it looks like WIndwos remomet Managemnt starts and goes down –  Natasha Thapa Jun 23 '11 at 21:45
    
I think you're looking for a dependent service, which you might be able to spot through services.msc on the dependencies tab. As a rule, you shouldn't IISReset unless you're making global changes to every app pool, which will typically recycle (i.e. kill and restart) all the app pools "cleanly" anyway. If that works, and IISReset is still flaky, it doesn't matter. –  TristanK Jun 23 '11 at 21:58
    
if anything is not working wouldn't that mean something is not working... when i check status of iis using iisreset /status it shows the windows management is down –  Natasha Thapa Jun 23 '11 at 23:09
    
I'm asking whether it's just IISReset that's broken, and a) it's recommended not to use it outside of specific circumstances, and b) it doesn't affect your application anyway, it might not be a meaningful failure. Do you use WinRM? –  TristanK Jun 24 '11 at 1:38
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.