Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My routing table on my machine with IP of 46.84.121.243 currently looks like this -

Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0     46.84.121.225     46.84.121.243     21
     46.84.121.224  255.255.255.224         On-link      46.84.121.243    276
     46.84.121.239  255.255.255.255         On-link      46.84.121.243     21
     46.84.121.243  255.255.255.255         On-link      46.84.121.243    276
     46.84.121.255  255.255.255.255         On-link      46.84.121.243    276

I'm trying to access 46.84.121.239, which is my other machine in the same DC but my guess is the first rule is blocking it as it is trying to go via the gateway and failing -

Tracing route to [46.84.121.239]
over a maximum of 30 hops:

  1  OWNEROR-9O83HBL [46.84.121.243]  reports: Destination host unreachable.

Trace complete.

I'm doing all this via RDP and already tried changing the metric on the persistent rule with devastating consequences! Here's the persistent rule (working) -

Persistent Routes:
  Network Address          Netmask  Gateway Address  Metric
          0.0.0.0          0.0.0.0     46.84.121.225       1

Any help to be able to access the 46.84.121.243 would be very helpful thanks very much.

share|improve this question
    
Devistating! It looks it is setup correctly to me. The 0.0.0.0 is just your default route. Can you ping the default gateway? Is the 46.84.121.225 the gateway of your NIC? has this every worked? Do you have any firewalls setup between the two? Is RDP enabled on your computer you're trying to connect to? –  Nixphoe Jun 22 '11 at 3:37
    
It's a connected network, the routes look fine. You need to troubleshoot firewalls most likely. –  SpacemanSpiff Jun 22 '11 at 4:01
    
Apologies everyone, it looks like the hoster in question has a strange setup, where connections in the same subnet need to go via the gateway rather than "on-link". –  gary Jun 22 '11 at 6:18

2 Answers 2

Since your subnet mask is a /27, this host and the destination are on the same network. You do not need that explicit route to 46.84.121.239.

Some things I would check:

  • Can both servers reach the gateway? I know the gateway would not be used here, but it will at least check that you have functional links on both servers.
  • Is the subnet mask set to 255.255.255.224 on both servers?
  • Does either server have a firewall running preventing IP communication?
  • Does "arp -a" show the remote host's IP and MAC address?

If none of those resolve your issue, then I was start looking at Layer 2 problems: misconfigured VLAN, port security, errors, etc.

share|improve this answer
    
arp -a dosen't show the remote hosts IP and Mac Address both servers can reach the gateway - firewall switch off on both –  gary Jun 22 '11 at 4:24
1  
Thanks for your help Doug, the hoster required connections to machines in the same domain to go via the gateway hence the "on-link" entries were causing a problem. –  gary Jun 22 '11 at 6:19

Doug's answer is correct the hoster in question (hetzner.de) informed me their network is on a "VLAN" and so even though the other host is on the same network the traffic had to go via the gateway.

So those "on-link" entries were not reaching the server even though it appeared on the same network, the solution was to force that traffic via the gateway using this persistent rule -

46.84.121.224  255.255.255.224     46.84.121.225       1
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.