Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I created a pub/pri key combo with putty. In putty I can set where the private key is, and login that way. BUT if I dont set my pri key , the server still asks for my password and lets me login. How do I prevent this?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

Assuming a *nix server (which would be good info to have), modify the /etc/ssh/sshd_config, setting PasswordAuthentication to no.

share|improve this answer
    
Got it 10 secs ago :) Thanks –  mike628 Jun 23 '11 at 1:25
1  
...and restart SSHD. –  dmourati Jun 23 '11 at 3:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.