Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've installed libevent on my server in the directory root/data/ and have i'm about to install memcached with

./configure –with-lib-event=/data/; make; make install

However, after running a bit I get this error saying i'm pointing to the wrong directory for libevent.

checking for libevent directory... configure: error: libevent is required.  You can get it from http://www.monkey.org/~provos/libevent/

      If it's already installed, specify its path using --with-libevent=/dir/

make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `install'.  Stop.

Any suggestions. I am not experience with cli so anything is help. Thanks!

share|improve this question

migrated from stackoverflow.com Jun 23 '11 at 2:18

This question came from our site for professional and enthusiast programmers.

    
Libevent probably is not in /data/. You could try to run configure without the flag and it will often look in default locations. If that doesnt work, then supply a path, but make sure its the path to the libevent header files. –  datasage Jun 23 '11 at 0:15
    
Why not install memcached using your server's package manager? This will save you a lot of time and effort. People more intimately involved with compiling software have already done most of the work for you. –  Sgaduuw Jul 21 at 10:27

1 Answer 1

Run:

find /lib /usr/lib /usr/local/lib | grep -i libevent.so

Then use directory it finds libevent.so as configuration parameter.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.