Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a small Ubuntu 10.10 server and i recently noticed a weird behavior (not sure if it was happening before). If I have ufw enabled (with default deny all in, allow all out, allow all http, allow all on a random port i use for ssh) when i perform some actions in a ssh sesion, the ssh console completely freezes. The server continues to work and if i close the console i can start another ssh session. This happens no matter from where I log in (tried from another ubuntu and a mac). The actions are fairly reproducible, for example vim some config files (though vim-ing other files works), cat some other file, etc. The freeze never happens if ufw is disabled. Any idea what's going on? Thanks! Cristian

Addition: if you're wondering, yes, I have TcpKeepAlive on yes and I doubt is related (it would happen with ufw disabled too)

As requested: my ufw conf below. Also, i don't know if it has something to do but the server has 2 ips. On one is configured the ssh domain, and on one to serve http (via apache2)

Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing)
New profiles: skip

To                         Action      From
--                         ------      ----
19922/tcp                  ALLOW IN    Anywhere
9418/tcp                   ALLOW IN    Anywhere
80/tcp                     ALLOW IN    Anywhere
443/tcp                    ALLOW IN    Anywhere
share|improve this question
    
It would help if you copy-pasted your ufw configuration, in case there's a typo you missed or something. –  Gilles Jun 23 '11 at 7:22
    
@Gilles : added ufw config in description. it's very basic, i doubt that there's something there. Hmm, now that i think about it, when i do ufw enable i always get "ERROR: problem running ufw-init". If I repeat the command, then it starts. –  Cristian Vrabie Jun 23 '11 at 7:55
    
Never used ufw, but what you want to do is allow already established sessions (and future RELATED, of course). –  3molo Jun 23 '11 at 10:20
add comment

1 Answer

up vote 0 down vote accepted

It seems that ufw has a problem with VPSs. Might be related to this: http://blog.bodhizazen.net/linux/how-to-use-ufw-in-openvz-templates/ I'll stick to using iptables.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.