Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using Jenkins 1.417 with the Subversion plugin. When I am trying to tag a build nothing happens. No message, no error, no tags created.

So, my question is - how to tag builds in Jenkins when the version control is Subversion?

Additional information:

When I am trying to tag a build without giving the credentials, the operation fails:

Tagging svn://dev-profiler/common/trunk (rev.65) to svn://dev-profiler/common/tags/Test-1
ERROR: Failed to tag
org.tmatesoft.svn.core.SVNCancelException: svn: No credential to try. Authentication failed
    at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.cancel(SVNErrorManager.java:37)
    at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.cancel(SVNErrorManager.java:32)
    at org.tmatesoft.svn.core.internal.wc.DefaultSVNAuthenticationManager.getFirstAuthentication(DefaultSVNAuthenticationManager.java:219)
    at org.tmatesoft.svn.core.internal.io.svn.sasl.SVNSaslAuthenticator.createSaslClient(SVNSaslAuthenticator.java:304)
    at org.tmatesoft.svn.core.internal.io.svn.sasl.SVNSaslAuthenticator.authenticate(SVNSaslAuthenticator.java:91)
    at org.tmatesoft.svn.core.internal.io.svn.SVNConnection.authenticate(SVNConnection.java:173)
    at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.authenticate(SVNRepositoryImpl.java:1265)
    at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.getCommitEditorInternal(SVNRepositoryImpl.java:1572)
    at org.tmatesoft.svn.core.io.SVNRepository.getCommitEditor(SVNRepository.java:2467)
    at org.tmatesoft.svn.core.internal.wc.SVNCopyDriver.copyReposToRepos(SVNCopyDriver.java:368)
    at org.tmatesoft.svn.core.internal.wc.SVNCopyDriver.setupCopy(SVNCopyDriver.java:628)
    at org.tmatesoft.svn.core.wc.SVNCopyClient.doCopy(SVNCopyClient.java:426)
    at hudson.scm.SubversionTagAction$TagWorkerThread.perform(SubversionTagAction.java:262)
    at hudson.model.TaskThread.run(TaskThread.java:126)
Caused by: org.tmatesoft.svn.core.SVNErrorMessage: svn: No credential to try. Authentication failed
    at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:200)
    at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:146)
    at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:89)
    ... 14 more
Completed

Which is good, because it is supposed to fail when no credentials are given. So the negative path is working as expected.

P.S.

Exactly the same problem is described here and on the jenkins issues site and on the respective google group. All to no avail.

P.P.S.

I realize that without logs little can be done, but one has to know the names of the loggers in order to activate them and thus generate the logs, which I do not know. If someone provides me with the logger names then I would gladly post the logs.

EDIT

I activated hudson.scm log to level All. This is what appears there:

03/07/2011 10:10:08 hudson.scm.SubversionSCM$DescriptorImpl$SVNAuthenticationProviderImpl fromProvider    FINE: global.requestClientAuthentication(svn.simple,svn://dev-profiler/common,<svn://dev-profiler:3690> Temporary Shunra Repository)=>null
03/07/2011 10:10:08 hudson.scm.SubversionSCM$DescriptorImpl$RemotableSVNAuthenticationProviderImpl getCredential    FINE: getCredential(<svn://dev-profiler:3690> Temporary Shunra Repository)=>null
03/07/2011 10:10:08 hudson.scm.SubversionSCM$DescriptorImpl$SVNAuthenticationProviderImpl fromProvider    FINE: local.requestClientAuthentication(svn.simple,svn://dev-profiler/common,<svn://dev-profiler:3690> Temporary Shunra Repository)=>null

Now, when I try to tag I see this error:

ERROR: Failed to tag
org.tmatesoft.svn.core.SVNCancelException: svn: No credential to try. Authentication failed
    at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.cancel(SVNErrorManager.java:37)
    at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.cancel(SVNErrorManager.java:32)
    at org.tmatesoft.svn.core.internal.wc.DefaultSVNAuthenticationManager.getFirstAuthentication(DefaultSVNAuthenticationManager.java:219)
    at org.tmatesoft.svn.core.internal.io.svn.sasl.SVNSaslAuthenticator.createSaslClient(SVNSaslAuthenticator.java:304)
    at org.tmatesoft.svn.core.internal.io.svn.sasl.SVNSaslAuthenticator.authenticate(SVNSaslAuthenticator.java:91)
    at org.tmatesoft.svn.core.internal.io.svn.SVNConnection.authenticate(SVNConnection.java:173)
    at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.authenticate(SVNRepositoryImpl.java:1265)
    at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.getCommitEditorInternal(SVNRepositoryImpl.java:1572)
    at org.tmatesoft.svn.core.io.SVNRepository.getCommitEditor(SVNRepository.java:2467)
    at org.tmatesoft.svn.core.internal.wc.SVNCopyDriver.copyReposToRepos(SVNCopyDriver.java:368)
    at org.tmatesoft.svn.core.internal.wc.SVNCopyDriver.setupCopy(SVNCopyDriver.java:628)
    at org.tmatesoft.svn.core.wc.SVNCopyClient.doCopy(SVNCopyClient.java:426)
    at hudson.scm.SubversionTagAction$TagWorkerThread.perform(SubversionTagAction.java:262)
    at hudson.model.TaskThread.run(TaskThread.java:126)
Caused by: org.tmatesoft.svn.core.SVNErrorMessage: svn: No credential to try. Authentication failed
    at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:200)
    at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:146)
    at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:89)
    ... 14 more
Completed

This is very strange, because I do provide the credentials...

share|improve this question
1  
Please edit this question to actually include the question. Do not send people offsite to read somebody elses question to even find out what you are trying to ask. –  Caleb Jun 23 '11 at 9:58
    
Also, it seems you already asked another question related to this. Since this one does not actually include the question I can't tell for sure, but it seems like they are asking about the same problem. Please just edit the first one to combine any useful data from this one. Using the promote builds plugin to tag subversion repository in jenkins –  Caleb Jun 23 '11 at 9:59
    
I have edited the question. It is not the same question as serverfault.com/questions/283313/… –  mark Jun 23 '11 at 12:45
    
again, please add a clear question to your post. I don't know what your asking! It should be really obvious, if you want people to help. –  Coops Jun 23 '11 at 12:52
    
Is it better now? –  mark Jun 23 '11 at 15:02
add comment

1 Answer 1

up vote 1 down vote accepted

How do you provide the credentials?

I had the same problem, due missing/wrong credentials. I followed the description in [1] where described how you can change/set credentials for SVN-repositories.

[1] http://weblogs.java.net/blog/felipegaucho/archive/2009/03/hudson_svncance.html

share|improve this answer
    
Thank you very much. This was indeed it! –  mark Jul 28 '11 at 11:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.