Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Recently we moved across a user and a distribution list from Exchange 2003 to 2010. The user used to be able to add and remove from a distribution list within Outlook.

I have added them to the Managed by list in Exchange in the distribution list, but to no avail. They are getting an error message saying You do not have the sufficient permissions to perform this operation on this object.

I cannot seem to find the setting to allow the user permissions.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

There appears to have been some changes to the way that user managed distribution lists are handled. To fix it requires assigning the MyDistributionGroups RBAC role to the Default Role Assignment Policy. The Technet script center has a script that should help you resolve this. A blog article describing the issue and resolution via the script is here.

share|improve this answer

I had a similar problem and found that by adding the user to the "Ownership" list it resolved the problem.

In 2010 you manage DLs through the OWA interface. Go to OWA then in top right click on Options -> See All Options.

On left hand side click on the "Groups" section and you will see a list of groups that you belong to and that you own.

If you double click the ones you own then you should be able to add this other user as an additional owner.

If you aren't the owner at the moment you can add yourself e.g. via powershell shell. One thing we did initially was to set the initial owner of ALL PFs to a specific user by using the command

get-distributiongroup | set-distributiongroup -ManagedBy "my.domain.com/MyBusiness/Users/Employees/John Smith"

Probably not the neatest powershell but you get the gist

share|improve this answer
    
Thank you, but I have already tried this, they are showing as an Owner. –  Matt Jun 23 '11 at 14:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.